Question Strange issue with M.2 SSd

JurkyB

Reputable
Aug 17, 2016
5
0
4,510
0
Hello everyone!

I'm kinda dumbfounded with my issue regarding an M.2 SSD (Adata XPG SX8200 PRO), let me sum it up in short (I will provide detailed description further down):

The new M.2 SSD shows up, works perfectly, nothing special, in the first cold start of the system. After shutdown and restart it doesn't show up ANYWHERE: BIOS, Disk management, device manager and so on. The only thing to make it appear again is to physically unplug the drive from the system completely, then connecting again. After doing that, I get one more cycle of start-up and shutdown that the drive is working. Couldn't find anything at all regarding to this, tried everything I found on like 30+ threads on various sites.


The problem, my tries with more detail:

So after I bought and connected the drive to my home pc, after some fiddling I figured out that I needed to partition it, and everything was fine (It got the letter "G", could write read just fine). I shut the computer down at the end of the day, and the next day after a cold start, it was like the drive vanished. After looking through several threads with issues of M.2 SSD-s not showing up, I could not find even one similar to my issue, however, I still tried all steps found there. Things I tried are the following (but not limited to these, however I cannot remember more, because this crap took a full day of my life so far...):

  • The SSD is a PCI-E one, and is supported by my mobo
  • While using an M.2 drive my mobo's manual says that SATA 1 and 2 are disabled, so I reconnected 2 drives to SATA 5 and 6 (however, the M.2 SSD worked the first time along SATA 1 and 2, so no clue here)
  • Updated my BIOS to the newest version
  • The Boot was already set for UEFI/AHCI mode, after changing AHCI to RAID, the system entered into a loop of boot and blue screen of death states, so changed it back to AHCI
  • There were no settings in BIOS to enable/disable M.2 drives, so no changes there
  • Disabled fast-boot and CSM
  • Cleared CMOS
Between these tries I also checked if the drive became disconnected somehow, and after taking it out of the port and blowing into it to clear it (note that the system is like 3-4 years old now, so dust could have gone there easily) and connecting it again, somehow it worked. What a relief I thought.
After the next startup, it did not show again.
After repeating the steps above, and the disconnecting, connecting several times, I figured that the drive only shows up after the first cold start of the connection, but not after the second (???). So far this is the only usable theory I could come up with....
Please note that I cannot simply make the system sleep/hibernate, since I cannot, it freezes upon wake up every-time, so I am not using that.. Also, always plugging in/out the M.2 drive is somewhat ridiculous for me, so that's a no way for that as well.....

I only would like to use the drive to store files and programs, not really as a boot drive.

Could anyone help me please??
Thanks in advance!


Here are my specs:

MOBO: ASUS MAXIMUS VIII RANGER (LGA1151)
CPU: Intel Core i7 6700
RAM: 16 GB HyperX DDR4
GPU: Gigabyte GTX980ti
OS: WIN10 pro
Storage: Kingston HyperX SSD 240 GB, WD 2TB HDD
 
Do you have anyone who can check that drive in another mainboard for similar symptoms?

Might be a weirdo compatibility issue not yet identified between your mainboard and that M.2 drive...

YOu will need to try a different identical Adata drive, or, a different M.2 drive....; waiting on a BIOS fix for potential compatibility issues with one NVME drive could be a long wait, if it were a BIOS issue..
 

JurkyB

Reputable
Aug 17, 2016
5
0
4,510
0
Thanks for the help! I can't really check the drive in another system, since I have noone with pc-s having M.2 slots. However, since the last reconnection of the drive it works as intended, after multiple startups.
I thought about returning it, but since it is working now I'll hold onto it for now, and worry about the rest later.
 

ASK THE COMMUNITY

TRENDING THREADS