• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Strange mouse and keyboard issue

May 11, 2020
3
0
10
0
Windows 10 64bit Version 1909 (OS Build 18363.815)
Intel Core i5-6400 2,70 Ghz
Nvidia Geforce GTX 1060
Mouse Trust GXT 111
Keyboard Trust GXT 860

Hello,
I have a strange mouse and keyboard issue and I was not able to find the solution anywhere.

It only happens in one game (Dota 2). My keyboard and mouse work normally and then out of nowhere both stop partially working. I don't even have to press anything, it happened multiple times when I didn't have my hands on either mouse or keyboard. On keyboard only ctrl, alt, alt gr, numlock keys work and on mouse both side buttons and wheel stop working. When i click left or right mouse button everything goes back to normal until it happens again. I don't hear any disconnect/connect sounds.

I have tried to update drivers, change both mouse and keyboard, factory reset of Windows 10, disabled 'allow computer to disable this device to save power' on both mouse and keyboard. Nothing made a difference.
Thanks for help.
Windows 10 64bit Version 1909 (OS Build 18363.815)
Intel Core i5-6400 2,70 Ghz
Nvidia Geforce GTX 1060
Mouse Trust GXT 111
Keyboard Trust GXT 860

Hello,
I have a strange mouse and keyboard issue and I was not able to find the solution anywhere.

It only happens in one game (Dota 2). My keyboard and mouse work normally and then out of nowhere both stop partially working. I don't even have to press anything, it happened multiple times when I didn't have my hands on either mouse or keyboard. On keyboard only ctrl, alt, alt gr, numlock keys work and on mouse both side buttons and wheel stop working. When i click left or right mouse button everything goes back to normal until it happens again. I don't hear any disconnect/connect sounds.

I have tried to update drivers, change both mouse and keyboard, disabled 'allow computer to disable this device to save power' on both mouse and keyboard. Nothing made a difference.
Thanks for help.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS