Question Strange ram problem

Mar 10, 2021
Rather odd one this one.
My computer has worked for years.

A few days ago, i bought a can of air, thermal pastes and solvants. Thought id give her a good clean out and see if we can bring my temperatures down a bit.

Upon reassembly she would not turn on.
By this ieam she was getting power, lights on, gpu lights on, fans running, hhd doing its thing. But no graphics out put.

After a couple power cycles id sometimes be able to access bios and it crash, other times no output to the monitor. Thought she was dead.

Today random thought, test the ram cards.
Now each ram card in slot 1, fully boots.
A single card tested in each slot, fully boots.
Pair the cards in slots 1&3 followed by 2&4 full boot.
Use all 4 slots at once, no screen outpit again

Anyone got any ideas whats up?

Motherboard: asrock 970DE/U3s3
Cpu: AMD FX-8350
Ram 4* xum dx8gddr3u1333
Gpu gefore gtx1080
Sound: sound blaster hd3 5020
Psu: strike-x 1100w
Hdd: western digital 1tb.

Yes i have documentation for all parts of my pc. (A habbit i picked up off my old man)
Ive checked tge cpu pins, everything looks straight.

Did a few more tests, every card works in every slot, and in every combination, including using 3 cards.

Though with me putting it away for the night, i inserted the 4th card and acidently turned it on this morning. Its booted up fine, and when i loaded up my task manager its only using 3 cards.
After loading cpuz, i can see that card 4 is in but not adding to the memory.
Last edited:


Update your post to include full system hardware specs and OS information.

PSU: make, model, wattage, age, condition?

Disk drives: make, model, capacity, how full?

For a computer that has "worked for years" it may be coincidental that things have gone astray.

Then again, what you did may have crossed some threshold between functional and not /no longer functional.

Do you have the motherboard's User Guide/Manual?

Refer to the motherboard's documentation to verify that you did indeed correctly reinstall and reconfigure all components.

Double-check using the applicable component documentation.