Question Strange recurring issue with headset mics

8shaky1

Distinguished
Dec 28, 2013
44
1
18,535
0
Hi guys,

Once again I am calling on the geniuses of this forum for help.
I have recently bought a new headset because my previous one stopped picking up audio on the microphone. I figured it was the headset as it was quite old and was due a new one. I have since bought a LOGITECH - G PRO X 7.1
It was working fine initially and I have had it for about a month now with no issues until today. The same issue has returned randomly. Nothing has changed on my pc, I just loaded it up today and initially I was getting all my sound through one side (left). I then took the wires out of the audio jack and blew on it to try and clean it out. This bought back my audio on both sides but now the microphone does not work. I have checked in windows for up to date drivers but all seems fine. I have tried putting the cables into a different pair of audio jacks but this didn't make a difference. It is not working when I test it in sound but also on discord.

Any ideas what could be happening here?

Thanks again!
Jake
 

Lutfij

Titan
Moderator
When posting a thread of troubleshooting nature, it's customary to include your full system's specs. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
OS: include OS version(not edition) if you're on Windows 10

Considering that the headset in question is USB driven, I'm inclined to think your OS or the USB driven sound card drivers have taken a detour from each other. Mind checking and seeing what BIOS version you're on for your platform's motherboard? You can use CPU-Z to show you the BIOS version listed under the Mainboard tab. You can try and reinstall your chipset/USB drivers and see if that helps. When installing any driver, install them in an elevated command, i.e, Right click installer>Run as Administrator.

As for the audio, are you working with Logitech's G hub app? If so, try uninstalling it and reinstalling it in said elevated command.
 

ASK THE COMMUNITY