[SOLVED] Strange sound problem after installing the latest NVidia driver 466.63

Alexoferith

Distinguished
Jun 13, 2013
125
3
18,715
7
I wonder if anyone can help. Today I have just installed the latest NVidia driver 466.63. I have been playing Far Cry New Dawn for the past two weeks with no problem. Oh sorry, my spec:
i9 10900
ASUS ROS Strix Z490E Gaming MB
32 GB RAM
2 TB Samsung 850 EVO SSD
2 x EVGA FTW3 1080Ti

I have absolutely no problem with the game until I have installed this latest driver. What happened is that whenever there is a cutscene or when I selected to talk to a NPC, the sound was all "muffled"! But if I was walking by a NPC, their greeting was normal, i.e. not muffled. Any idea? Many thanks for your help in advance.
 

Lutfij

Titan
Moderator
Can you check and see what BIOS version you're on at the time of writing? Version 21H1 for Windows 10? Make and model of the PSU powering the system and it's age(if it's been in use for a while)? Assuming you have the installer for the latest drivers on your system, use DDU to uninstall your current GPU drivers, reboot, then reinstall with the latest sourced prior in an elevated command, i.e, Right click installer>Run as Administrator.
 

Lutfij

Titan
Moderator
Can you check and see what BIOS version you're on at the time of writing? Version 21H1 for Windows 10? Make and model of the PSU powering the system and it's age(if it's been in use for a while)? Assuming you have the installer for the latest drivers on your system, use DDU to uninstall your current GPU drivers, reboot, then reinstall with the latest sourced prior in an elevated command, i.e, Right click installer>Run as Administrator.
 

Alexoferith

Distinguished
Jun 13, 2013
125
3
18,715
7
Can you check and see what BIOS version you're on at the time of writing? Version 21H1 for Windows 10? Make and model of the PSU powering the system and it's age(if it's been in use for a while)? Assuming you have the installer for the latest drivers on your system, use DDU to uninstall your current GPU drivers, reboot, then reinstall with the latest sourced prior in an elevated command, i.e, Right click installer>Run as Administrator.
Hi, thank you for the quick response. BIOS? Which BIOS? Do you mean the GPU? If it is GPU, it is 86.02.39.40.92. And if you mean the MB, it is 0607. Yes, it is 21H1 for Windows 10 Pro 64bit. PSU was bought and installed in Aug 2020 and it is EVGA SuperNOVA G3 1000W.
 

ASK THE COMMUNITY