Question Strange Stutter/Hitching Since Windows 10 Reinstall

Feb 23, 2020
2
0
10
0
Hi everyone!

First things first, here's my setup:
MotherboardMSI X370 Gaming Pro Carbon
CPUAMD Ryzen 7 2700X
GPUGTX 1080 Ti
RAM16GB DDR4
Power SupplyEVGA Supernova NEX750B


I've been having some pretty strange issues with my computer recently, though the problems aren't entirely new. I built this system about a year and a half ago, and had some of the same issues for a short while before they eventually faded and I basically forgot about it. I recently had to completely reinstall windows because I was getting errors whenever I tried to update. Ever since the reinstall, these issues have come back.
Basically, I experience a lot of small hitching and stutters while using any and all programs on the computer, normally causing a brief black screen and audio lag. These events are preceded by a second or two where I can still move the mouse around, but videos freeze and I'm unable to do anything. Video players seem to trigger this the most, and it regularly happens multiple times per video, and regularly during live streams. I can't capture this behavior with recording software, because that software will crash during these hitches. No error messages appear after these hitches, and occasionally (not every time) the video player will completely shut down and I'll have to refresh the tab.
I've tried various things to pinpoint the issue, but haven't been very successful.
I ran LatencyMon, and these were the results


CPU 0 seems to be having some issues, but I really don't have any idea what this information means or how to fix this.
Running Speccy also showed that my CPU was running at around 95C - though I'm not entirely sure how accurate this is. I've checked temps in the BIOS, and there it's shown to be more in the 32-37C range. My build doesn't radiate much if any heat, and even when holding my hand directly next to the CPU/Fan I couldn't feel anything abnormal.
CPU load is almost always low during these events as well, it occurs when using apps like Chrome, Spotify, and other non intensive programs.

While playing video games, I will get very frequent hitching and stutters as well, but no longer get sent to a black screen. I really don't have much more information when games are concerned however, as I haven't played more than a handful of games recently. I will say however, that when "new" things are happening, this stuttering happens more frequently. After things have been loaded in an area the frequency drops a little, though the problem certainly still persists.

Overall my gut feeling is that there's a software issue at play here, as I haven't physically messed with anything in a long while beyond some non intrusive cleaning. The issue also only reappeared after the windows reinstall. Thanks for taking the time to read all this! Any tips or thoughts or similar experiences are welcome and appreciated.

Also, I'm not entirely sure which forum is the best for this type of issue, so feel free to move it if this isn't the right place.
 
Feb 23, 2020
2
0
10
0
Does this issue seem to reflect something being wrong with the power supply?
Unfortunately I don't have access to an alternative to test right now
 

ASK THE COMMUNITY

TRENDING THREADS