Question Strange USB issue on ASUS Maximus XII Formula ?

eazy11

Reputable
Jan 12, 2017
9
1
4,515
0
Hello everyone!

A couple of days ago I had to unplug everything from the computer since I replaced stuff in my room and when I plugged in the keyboard (that I use for years) into the back USB port where it was plugged in before, the computer automatically turned on and was stuck in an on/off loop for like 20 seconds. Eventually it turned on for good (no restarts) but I got a post message saying that BIOS was recovered. I went to BIOS only to see that everything there was reset to default settings, but the BIOS version was still the one that I previously updated (I was on version 0805 which was released couple of weeks ago). I have never had any issues with this build before and I do not seem to have any issues currently ever since this happened. I have stress tested the computer for about 2 days now and there are 0 stability issues, no restarts, no BSODS, nothing. Everything seems to work fine.

Full PC Specs:
ASUS Maximus XII Formula, now I have updated the BIOS to latest version 0901
CPU: i9 10900k (not OC)
RAM: 2x16GB 3000 MHz
PSU: Seasonic Prime SSR-850PD 850 Watts
GPU: ASUS ROG STRIX 1080Ti
Storage: 2x m.2 PCI SSD + 2x SATA SSD + 1x HDD

So did anyone every experience something like this? Should I be worried? Could it be the PSU, although I know that USB power is handled by the motherboard itself?

PS: the USB ports were powered on even when the PC was turned off because of the ERP setting in BIOS.
 

ASK THE COMMUNITY

TRENDING THREADS