Strange XFX RX 560 memory clock behavior leading to sudden shutdowns

Grimnakk

Prominent
May 22, 2017
7
0
510
0
Hey Tom's. So, I've bought this XFX RX 560 card some months ago noticed its memory clock is forever stuck at 1500 MHz (maximum for stock configuration) even when idling. On top of that, the computer would crash ramdomly when playing some games (especially Guilty Gear Xrd and The Witcher 3; it would never crash when I'm idling). The crash timings are rather inconsistent: sometimes 10 minutes is enough, other times it won't crash at all. I monitor the temperatures all the time, and neither the GPU's or CPU's would go above 60 ºC.
One thing I've done to jury-rig it for a while until can I pinpoint the problem was to download MSI Afterburner and set the memory clock down to 1300 MHz, where in addition to fixing the stuck memory clock to a dynamic setting (300 MHz when idling, going up to 1300 when gaming), it also made the crashes stop in Guilty Gear (though it'd still sometimes crash in The Witcher 3).
I thought it could have been a faulty PSU, but even after installing a brand new Corsair CX 550, if the memory clock is set at the default 1500 MHz, the crashes still occur. My BIOS is the latest one available and my drivers are clean, since I've even tried reinstalling Windows but no dice. Also, the crashes are those where the screen would show a random solid color with this quick sound loop for a while and leading to a system reboot. No bluescreens.
My question is: can I be at least convinced it's a faulty GPU or are there other components that can lead to these shutdowns? The card is still at warranty but I want to make sure the problem is with it before I send it back to the shop to avoid losing time and money for shipping. Thanks.

The specs go as:
Gigabyte 78LMT-S2P
Phenom II X4 965
2x4GB Kingstom RAM @667 MHz
XFX RX 560D 4GB
Corsair CX 550
 

Grimnakk

Prominent
May 22, 2017
7
0
510
0
Yeah, one thing I forgot to check or mention in my post is that I don't know if my chipset driver is up to date. I bet it isn't since I had to update my MOBO BIOS myself but what do you guys think? Is it worth a shot?
 

ASK THE COMMUNITY

TRENDING THREADS