Strangest hard drive issue ever

Cixpax

Honorable
May 17, 2012
2
0
10,510
The strangest thing ever just happened to me in the 10 years I have been working on computers. I was trying to update a OCZ SSD via USB (something I just found out you cannot do) because OCZ thinks its ok that you have to update the firmware from an entirely separate drive (huge inconvenience). Anyway, so I put it in the USB dock, this:
http://www.newegg.com/Product/Product.aspx?Item=N82E16817182221

and tried to update it. I couldn't get the drive to be recognized under My Computer, but I was able to see it in Disk Management so I formatted that way assuming then I could update the firmware. I then could see the drive, but somehow this fried the dock, and now the SSD no longer can be viewed in the BIOS or anything. Assuming it was just the drive and not the dock I put another Hard-Drive (a Brand New 3.5" 2TB Spindle Drive) and the dock somehow made that drive completely unusable when I tired to view it.

I have tested these 2 drives on multiple computers and ports with no results, I cannot view them in the BIOS, under disc management and the SATA ports in the BIOS say "empty" when I am directly connected.

What could have happened? And is their anyway to fix this without replacing them?

Very strange.

PS I am absolutely positive the dock did this to the drives.
 
Solution
Sounds like the dock is defective and damaged the 2 drives that were inserted into it. If I understand what you are saying; you had a SSD and a HDD that were in working order. After being connected to the dock they are no longer being recognized by any systems they are connected to. If this is the situation, I would think damage has been done to the interface electronics. These circuits are voltage sensitive. Nothing to do here but send the drives to the factory for a warrenty replacement. As to the dock I might drop a large rock on it or send it back for a refund. I do not think you would ever get Rosewill to admit their product damaged the drives. I would post a big zero eggs feedback.

Dogsnake

Distinguished
Sounds like the dock is defective and damaged the 2 drives that were inserted into it. If I understand what you are saying; you had a SSD and a HDD that were in working order. After being connected to the dock they are no longer being recognized by any systems they are connected to. If this is the situation, I would think damage has been done to the interface electronics. These circuits are voltage sensitive. Nothing to do here but send the drives to the factory for a warrenty replacement. As to the dock I might drop a large rock on it or send it back for a refund. I do not think you would ever get Rosewill to admit their product damaged the drives. I would post a big zero eggs feedback.
 
Solution