Question Stream is skipping frames when playing games when I stream in 900p/60fps ?

hunterstacy

Prominent
Dec 8, 2019
21
2
515
0
Specs:
i7 8700
GTX 3060
16 GB RAM
600 WATT PSU


I am getting major frames skipping and getting really choppy even in games that aren't demanding... I know my bitrate is at 6k but all of my other settings in Streamlabs OBS are at default. I don't know what could cause this but my PC should def be able to handle all of this.
 

Lutfij

Titan
Moderator
Make and model of your motherboard? BIOS version for said motherboard? 600W is the wattage of the PSU, it does not state the make and model of the unit. We will also need to know what the age of the PSU is. What was your GPU prior to the RTX3060? Did you use DDU to uninstall your GPU drivers prior to powering down and then dropping the RTX3060 in? You're advised to reinstall the latest GPU drivers in an elevated command, i.e, Right click installer>Run as Administrator.

Speaking of administrator, what OS version are you working with, assuming you're on Windows 10?
 

hunterstacy

Prominent
Dec 8, 2019
21
2
515
0
Here is my motherboard MSI MPG Z390 GAMING PLUS LGA 1151 (300 Series) Intel Z390 SATA 6Gb/s ATX Intel Motherboard
Here is my PSU EVGA - W1 Series 600W ATX 12V/EPS 12V 80 Plus Power Supply - Black
My BIOS version for my motherboard is American Megatrends Inc. 1.60, 3/27/2019
The PSU is pretty much brand new used for about two weeks now.
I used a 1050ti and did uninstall my GPU drivers also using Windows 10
 

ASK THE COMMUNITY

TRENDING THREADS