Question Strix B450 F Red light issue

V Gaming

Commendable
Dec 25, 2016
35
2
1,535
0
So this issue started yesterday i was playing and suddenly the power went off (Im from Pakistan and there is a thing called loadshedding where the power goes off anytime)and when power came back on i presssed start button on pc all fans lights etc start for a second mobo showed orange light then red light and shut down itself. tried to boot multiple times but same redlight.Just after some some mins 3-4 i tried starting it up and it booted showing me this message(image attached) pressed F1 and it booted normally . Later again the power went off and it did the same thing .ive been using this pc for 6 months a
nd it never reacted that way when electricity goes off. I wanted to ask if the message showing above tells that something is faulty.i tried clearing cmos reseating rams, gpu even taking the ram speed back to 2133 from 3000 but nothing seems to work.

Specs
Ryzen 2600
Strix B450 Gaming F
2x8gb trident z rgb 3000mhz
Corsair VS 650
Gigabyt GTX 1050ti
 

DMAN999

Reputable
Herald
Try putting just One RAM stick in Slot A2 and see if it boots normally.
If it does then power down and try just the other stick in slot A2.
If both boot fine one at a time then run Memtest86 on each stick individually and see if they both pass without any errors.

Also what BIOS are you using ?
BIOS 1201 is the Best BIOS for a Ryzen 2000 Series CPU.

And sadly since you have a very poor quality PSU, it may have shorted your motherboard when the power went out.
 

DMAN999

Reputable
Herald
Try taking the plug lead out of your psu and then hold the power button in for 10 seconds. Then plug back in the lead and see if it posts correctly.
Actually with this MB at least he needs to hold that Power Button in for at least 30 to 40 seconds before clearing the CMOS.
I just cleared my CMOS (multiple times) on that MB when I was upgrading my BIOS one version at a time before installing my 3700x on it and the Onboard RGBs go off when you unplug it BUT will come back on after about 20 to 30 seconds and then turn off again when you are holding the Power Button in.
 

V Gaming

Commendable
Dec 25, 2016
35
2
1,535
0
Try putting just One RAM stick in Slot A2 and see if it boots normally.
If it does then power down and try just the other stick in slot A2.
If both boot fine one at a time then run Memtest86 on each stick individually and see if they both pass without any errors.

Also what BIOS are you using ?
BIOS 1201 is the Best BIOS for a Ryzen 2000 Series CPU.

And sadly since you have a very poor quality PSU, it may have shorted your motherboard when the power went out.
motherboard doesnt looks like its shorted the pc is working fine right now it only reacts this way when the power goes off and i tried both rams (one at a time) and it booted fine.Not sure abt BOIS version, updated it only once 3 months ago.i built this pc in january earlier this year
 
Reactions: DMAN999

ASK THE COMMUNITY

TRENDING THREADS