Question STRIX MotherBoard lights on but no boot

Apr 29, 2019
37
0
30
0
Hello I have a Strix X270 mobo and i have alots of problems with it. Most of the time it won't boot and i have to wiggle the power switch and press the power button alot for it to turn on, when it turns on i get either the cpu red light (very few), it will boot into BIOS without detecting SSD or i get stuck in the white vga LED but most of the time it won't turn on. I updated BIOS i know its none of my hardware including the PSU because if I use my old H110 Biostar everything works like a charm. It always double boot (turns on then off and on automatically). No, the mobo doesn't touch any metal from the case because even if i put it on its box and try it doesn't work. Please someone help! :(

Strix Z270F
Intel I5 7400
Hynix 8Gb 2133
MSI GTX 1060
HIKVision 240+480Gb

Now the PC is on and is working very well but if i turn it off and leave for more than 15 min off it will not boot again
 
Apr 29, 2019
37
0
30
0
if you think the issue is the motherboard, why not replace it?
Because I bought it 2nd hand from someone that is no longer living here. And after BIOS update it worked fine for a couple of month then crashed again. I cannot afford another board right now and my liquid setup is broken so im back with fans and i don't want to come back to Biostar where i can't control my fans.

Anyway if its powered on now and i can even turn it off and directly turn it back on why can't it stay like this all the time? what is causing this problem?
 

ASK THE COMMUNITY