Question Stuck at BIOS screen after BIOS 0120 update

Nov 16, 2019
2
0
10
0
Hi there,
I have just bought a AMD Radeon RX 550, after a few tests the screen won't post with the GPU inserted. So after a while I decided to update the BIOS system.

First I had to install 0048, after that 0099. All were clear installs and booting to Windows in perfect working state, but after attempting to install the 0120 BIOS update officially meant to work on the Intel DH61WW mobo, the BIOS screen is stuck on the screen showing Intel Desktop board with the F2/F7/F10 BIOS options. NOTE: The GPU was set aside from the first BIOS update!

I have tried these, but failed:
  • Resetting the BIOS (3-pin removal, CMOS battery removal and F9-reset on BIOS settings)
  • Attempting to boot from a USB (but screen freezes)
  • Attempting F7 to install a previous version of BIOS (Bootable .BIO file via USB) - screen freezes on Yes [Enter]
  • Removing RAM cards (both were removed seperate, shown: Warning: Memory size decreases; Freezes when enter key is entered)
  • Booting without any HDD or pendrive (same)
  • Installing Windows via Bootable drive (can't even boot)
Possible helpful specs:
  • Intel DH61WW Desktop Board
  • Intel i3-2100 3.1 gHz
  • BIOS 0099 'settings' working
  • 6 GB RAM (2+4 DDR3)
Tell me if you need any other specs

Can anyone help or assist me, because the internet seem to give me only answers of CMOS resetting, which I tried million times.
 
If the PC won't post with the GPU inserted, it may be caused by having a motherboard with non-UEFI BIOS. People have reported problems getting the RX series of cards working on some legacy BIOS motherboards.

Motherboard manufacturers don't want to deal with troubleshooting issues from old motherboards. I suggest trying an older video card.

System Requirements for RX 550:
400W or greater Power Supply
 
Reactions: 1w8n
Nov 16, 2019
2
0
10
0
Thanks Calvin! I appreciate your help!

My actual problem was that I didn’t update the BIOS correctly.

The BIOS version that was on the mobo didn’t have an UEFI option to the HDD. After updating the BIOS to 0099 (from 0028), it had the option to UEFI, but I updated to 0120 and the motherboard freezed and malfunctioned. Though it would’ve worked on that mobo (which is now bricked), I decided to buy a new motherboard to ensure that the GPU will work.
 

ASK THE COMMUNITY

TRENDING THREADS