Question Stuck in a boot loop GA-Z97x Gaming 7 motherboard


May 2, 2013
Hi guys, so my friend has a problem and has asked me to help solve it. His PC randomly blue screened one day with the error "whea_uncorrectable_error", and then the PC would not boot, lights and fans boot up but it shuts down and then starts up then shuts down etc. He left his pc off for a few days, turned it back on and it actually loaded up, however it BSOD again, with the same error, he has brought it over to me and I am getting the same issue with it now booting then restarting constantly.

I have taken it apart, reset CMOS, tried with and without GPU, SSD, HDD, RAM, tried different RAM slots, removed the actual CPU, checked for any bent pins, replaced thermal paste, etc etc. It still is stuck in this endless loop of powering up then shutting down. The only thing that has made the computer actually stay on is manually flicking the dual bios switch to dual bios instead of single, when I do this all lights and fans stay on, but it outputs no display either on GPU or onboard graphics, I also tried to use the backup bios and it still just keeps looping. There is also no error showing on the debug LED.

The motherboard is a GIGABYTE z97x gaming 7, CPU is i7 4790k and GPU is Nvidia GTX 970.

Any ideas here guys? Is the motherboard the issue?