Question Stuck in American Megatrends screen after hardware change

Jan 14, 2021
61
3
35
0
I recently changed my motherboard, I got the bios on a USB, plugged my new motherboard in (Asus rog B450-F Gaming 2) but when I get the update bios screen it says Press F1 to startup, but it doesn't enable me to go into bios. I think I got the first version of the motherboard board bios instead of the second version but I'm pretty sure it should still enable me to access bios? My specs are 16gb corsair vengeance Pro ram, rx580,H100i AIO cooler, the new motherboard (Asus B450-F Gaming II) and a ryzen 5 2600x
https://photos.app.goo.gl/DLPo6n5k4yYzKvQE7
 

Lutfij

Titan
Moderator
Oh my, you went from your prior thread to here...

You're currently on BIOS version 0301. You should be on version 4301, ideally. Since you're on 0301, you should gradually work your way to 4007>4204>4301. Make and model of your PSU?
 
Jan 14, 2021
61
3
35
0
Oh my, you went from your prior thread to here...

You're currently on BIOS version 0301. You should be on version 4301, ideally. Since you're on 0301, you should gradually work your way to 4007>4204>4301. Make and model of your PSU?
Yeah, because my earlier issue wasnt this. My psu is EVGA 600w.How would I do that please? Just download the latest available bios and retry? But I'm still doubtful it'll let me access bios after trying to press F1. I've also tried other keys and to no avail.
 
Jan 14, 2021
61
3
35
0
I recently updated my BIOS and after that all I get is a black screen. When it loads up it comes up with the American megatrends screen and tells me to access bios ect, but then when I press save and restart it comes up with Windows error, and the repair tool gives me the black screen. I only updated bios, haven't messed around with it. My specs are

Corsair vengeance 16gb ddr4 ram
ryzen 5 2600x
evga 600w psu
RX 580

My old motherboard was Asus Prime B450M-AII, if that's any help
 

ASK THE COMMUNITY

TRENDING THREADS