Question stuck on 800x600 and 640x480 pls help

Feb 11, 2021
4
0
10
0
Hi guys, I'm so tired, I've tried everything already.

Just bougth a gigabyte rx 570 4gb and I can't make it work. The graphic card I used before this one is a gtx 750ti 2gb and it is working perfectly.

The problem I have is that my resolution is stuck at 800x600 or 640x480.

specs:
GIGABYTE RX 570 4G
RAM 8GB DDR3
GENERIC H77 MOTHERBOARD
EVGA 500W 80PLUS
I7 3770K
SCREEN IS AOC 2250

what ive tried so far:
  • Uninstall drivers with DDU several times
  • Installed a bunch of different driver version
  • Clean installation with two different versions of W10 and W7
  • Switched to another motherboard
  • Flashed original VBIOS with ati flash
  • Patched drivers with atikmdag
  • Tried with a working DVI connector(the one I used with my gtx 750ti) and HDMI with another screen
  • Updated screen drivers
  • Tried customs resolutions and every way possible to change my resolution
I don't really know what else to do. I hope u guys can help me out. Graphic card is known working, tried on a different pc, no problem at all.

Before drivers installation resolution is stuck on 800x600, after I install em it gets stuck on 640x480. This happens everytime I do it.

It is plugged with a 6+2 pin connector and drivers install without any problem. Please help and sorry for my bad english.
 
Last edited:
Feb 9, 2021
84
18
45
2
You mentioned that the GIGABYTE RX 570 4G is in working condition and you tested it on another PC. What is the spec of the that pc. I'm trying to narrow down the possible causes.
 
Feb 11, 2021
4
0
10
0
You mentioned that the GIGABYTE RX 570 4G is in working condition and you tested it on another PC. What is the spec of the that pc. I'm trying to narrow down the possible causes.
It is the same exact PC but it has generic 650watt psu and a different screen monitor. Everythikg but that is the exact same PC.

And yes, I tried with different displays already.
 

ASK THE COMMUNITY