Stuck on ASUS “In Search Of Incredible” Screen.

Sep 8, 2018
1
0
10
0
Hello,

I am currently having a problem with my computer, where it’s just stuck on the “Asus In search Of Incredible” screen. I’ve tried multiple things such as:

• Reseting the CMOS (which didn’t help at all)
• Taking out both ram sticks (the computer itself turned on but no accessory, nor the monitor would turn on)
• Took out the small little silver battery on my motherboard for 10 minutes.

None of these worked and i’m just really desperate to get my computer working again. I also can’t access the BIOS settings. No keystroke is responsive. I’ll leave my specs down below.

• CPU: i5 4690K
• GPU: EVGA GTX 960 4GB
• Motherboard: Asus Z97-K
• Ram: 16GB (HyperX Fury - 2x 8GB Sticks)

Please, if anyone can help me, it would be much appreciated. I need it badly for school and stuff.
 
It sounds like the computer is failing to POST (Power on self test). If you had a PC speaker, it might give you a beep code to help identify the issue.

Did you try taking out just 1 ram stick?

Normally, I would strip the computer of everything that is plugged into the motherboard (USB stuff too), leaving just one RAM stick, CPU, and CPU cooler . Unfortunately, I don't see a way to know if it has successfully posted in this configuration (some boards have a status LED), so you would need a video card. It would be nice if you could get your hands on some low power card to test with. If I was able to get a successful POST, I would then start plugging things in one at a time to see what part is failing. If you can't get a successful POST with just MB, CPU, and 1 RAM, then you know it is probably your PSU, MB, or CPU that has failed (pretty much in that order).
 

ASK THE COMMUNITY

TRENDING THREADS