Question Stuck on motherboard screen

Jan 15, 2020
3
0
10
0
I downloaded an update for my RX5700XT graphics card and installed it. PC asked for a restart so i did. After the restart the pc got stuck with the logo of the motherboard and the loading dots of windows10.
I got into safe mode and deleted the update, nothing happened. Tried to do format for windows and it didn't format and now i can't even get into safemode. What to guys please help me i'm desperate

Specs:
CPU: Ryzen 5 3600
GPU: RX5700XT msi mech
Motherboard: asrock b450m hdv 4.0
RAM: XFG 2×8 16GB 3200mhz
Powersupply: evga 700w 80plus
System: windows10 x64
 
Last edited:

me 1

Distinguished
Oct 2, 2010
846
5
19,065
29
What do you mean deleted the update.? Didn' t you uninstall it?
If you reached safe mode , you should have uninstalled it from there or checked if you can do a System restore to an earlier time.
But you formated?!
Format will erase your drive, no wonder you can't get back to safe mode.
How did you try to format? And what? The partition with the system?
Did you tried to do a clean install of windows?
What happened?
 
Jan 15, 2020
3
0
10
0
What do you mean deleted the update.? Didn' t you uninstall it?
If you reached safe mode , you should have uninstalled it from there or checked if you can do a System restore to an earlier time.
But you formated?!
Format will erase your drive, no wonder you can't get back to safe mode.
How did you try to format? And what? The partition with the system?
Did you tried to do a clean install of windows?
What happened?
Sir i uninstalled the update. I didn't check for a system restore. I got into troubleshoot mode and looked for a restart for the whole system, i clicked "delete all files including personal files" then got taken back to the logo of motherboard with the loading dots circling forever
 
Jan 15, 2020
3
0
10
0
Guys after a lot of attempts to restore the system i haven't found a solution so i grabbed a flashdrive and installed a new system entirely
 

ASK THE COMMUNITY