Question Stuck on "Republic of gamers screen"

Jul 14, 2021
2
0
10
0
Hey,
I just upgraded my Mobo and CPU. My PC was working after the installation but only for an hour or so. The PC freezes at the ROG screen after BIOS. I'm not running any overclock at the moment.

Specs
  • Ryzen 5600x
  • ASUS ROG GTX 1070 (vert mounted)
  • ASUS ROG B550-A mobo
  • 2x8 GB corsair vengeance @3000MHz
  • 500 GB Samsung 860 Evo SSD
  • Seagate 2TB HDD
  • Corsair RM 550x
  • NZXT x62 kraken cooler
Solutions I have tried already
  • reset CMOS
  • updated BIOS
  • removed USB devices/changed keyboard
  • re-insert GPU and RAM
  • check for loose cables
I was thinking it could be an issue with the watts of the PSU. Also the Mobo has an extra 4 pin power plug that I do not have a cable for. Maybe I have to reinstall windows? Any help would be greatly appreciated!
 

alexbirdie

Notable
Feb 20, 2020
416
83
840
38
If you did connect the 8-pin-power-plug, you need not connect the 4-pin-plug, too.

"ASUS ROG GTX 1070 (vert mounted) " .... Didi you try to put it into MB-PCIe-slot without Riser-cable?

Ram: XMP activated ( other name DOCP)? If yes, try it with slower non XMP-speed.
 
Jul 14, 2021
2
0
10
0
If you did connect the 8-pin-power-plug, you need not connect the 4-pin-plug, too.

"ASUS ROG GTX 1070 (vert mounted) " .... Didi you try to put it into MB-PCIe-slot without Riser-cable?

Ram: XMP activated ( other name DOCP)? If yes, try it with slower non XMP-speed.
That is good to know about the power connectors. Yes, I have a riser-cable installed and I don't have DPCP/XMP enabled. I reinstalled windows just now which seemed to fix my problem.
Thanks for the reply
 

alexbirdie

Notable
Feb 20, 2020
416
83
840
38
If I do have any problems, I try a lot of different things before doing a new windows install. thx god, until now everything is working fine for me.

But:

Good to hear, that you problems is solved. Hoping for you , that no further problems will occur.

regards
 

ASK THE COMMUNITY

TRENDING THREADS