Question Stuttering and lagging when connecting laptop to external monitor and closing lid ?

May 19, 2022
Hello there!

So I am having an issue with my laptop and external monitor right now, in which every time I hook up my laptop the monitor, and close the lid like I have always done, the display on the monitor is very laggy and stuttering, but it only applies to when I am scrolling or moving windows around or closing and opening windows/applications. The funny thing is, this problem only happens when I am on Windows 10, as I had updated to Windows 11 in hopes of the problem fixing itself and it did, but unfortunately I am not a huge fan of Windows 11.

Furthermore, I have tested it a bit more and it seems like my laptop is the issue, as I have tried this with other Windows 10 laptops and different HDMI cables and they all seem to work perfectly fine. And one more thing to note is that my laptop on its own is completely fine when not hooked up to a monitor, and if I choose the "duplicate the display" option then it works perfectly fine on both screens, so the issue only happens when I hook my laptop up to the monitor and then close the laptop lid, which is something I have been doing for years now without issue.

The reason I close the lid is because once I do it, the entirety of the display is transferred to the external monitor screen, which is what I prefer rather than having it display it on both screens at once at 144hz which causes it to lag. Furthermore, I have already tried the options of "display only on 2" and "make this my main display" and nothing seems to work. Could it possibly be an issue with the Hz? As when I use 60hz rather than 144hz for the monitor display, it seems to work just fine, but of course 60hz is extremely laggy and unplayable for me.

Edit: I forgot to add that this issue started happening after I updated my system BIOS! I am currently using a Lenovo Legion 5 IMH05 IY86 model, and the BIOS version I am currently using is efcn54ww. However, I did try doing a bios backflash and downgrading to older BIOS models and it still was not working, so I am not sure if the BIOS update is the issue or not.
Last edited: