Question Stuttering, and Programs are opening slower than before

Feb 11, 2021
10
0
10
0
Hi everyone I am new here but would like to ask a question I can’t seem to figure out. I downloaded new Nvidia drivers and rolled back after stuttering occurred but my stutter and lag problem has not been fixed I’m not sure if it is a hardware issues now or if the drivers are still causing trouble. I used custom install to do a clean install of the drivers and also used DDU. I wasn’t sure if it was now becoming a PSU,RAM or SSD problem now since I’ve tried all the fixes for the drivers. My computer has also been opening google way slower then it use to. The google chrome browser use to open instantly now it takes about 30secs to a minute to open up.
Cpu: I9900k
GPU: RTX 2080 super
PSU: EVGA 650 bronze

sorry if I need anymore information or wrong format I am still learning and just looking for help if I need to change anything just let me know.
Thanks in advance!
 

Ralston18

Titan
Moderator
And I will add the suggestion that you use Resource Monitor and Task Manager (just one at a time) to observe system performance.

Determine what resources are being used. To what extent (%), and what is using any given resource.

Open Resource Monitor (or Task Manager) and drag the window to one side or the other. Watch for awhile and allow the system to stabilize.

Then launch Chrome and see what change(s) occur.

It may take a few tries to pinpoint some particular change or issue....
 
Reactions: Dirtyymeat
Feb 11, 2021
10
0
10
0
what the ssd? how full it is?
how much ram?
malware scan the system?
check cpu temp?
what the ssd? how full it is?
how much ram?
malware scan the system?
check cpu temp?
It’s a Sandisk 1TB SSD the SSD has about 10GB left on it.
I have 2x8GB sticks of ram
I did the windows defender scan on my computer and it didn’t pickup anything
CPU temps were sitting around 40-50 while in use
 

ASK THE COMMUNITY

TRENDING THREADS