Question Stuttering In All Games Even With Gsync - Driving Me Insane

Status
Not open for further replies.

bbacker26

Reputable
Dec 26, 2017
17
0
4,510
0
So I am having a major stutter issue with every game I play even with G-sync enabled. My monitor is a 165hz g-sync Asus monitor. I followed the Blur Buster Optimal Gsync settings https://blurbusters.com/gsync/gsync101-input-lag-tests-and-settings/14/, which say to set an fps cap 3 frames lower than your refresh rate and vsync enabled in NVCP. What happens when gaming is my capped fps (162), will sometimes drop to sometimes only 161 fps, yet there is a very noticeable micro stutter that occurs. What really confuses me is my rig (rtx 2080ti, 9700k) is more than capable of outputting framerates much higher than 162 fps. So this makes me question why these small fps drops/stutters are even occuring in the first place. I even tried lowering the refresh rate to 144hz and capping a 141fps and yet these fps drops/stutter still occur.

What I have done:
Fresh Windows Install
Reinstalled All Drivers (used DDU)
Swapped monitor cables
Turned off Anti Virus
Closed All background tasks
Updated Bios
Almost every other troubleshooting idea you cant think of

If anyone has any input or ideas please let me know because I am desperate!
 

boju

Titan
Ambassador
Which games are you having trouble in?

Try remove fps cap. Which fps cap program are you using? Close that too. Then try Vsync in NvidiaCP to application control and use the game's own vsync engine.

Another thing you can try is check disable fullscreen optimisation under compatibility for the game's app/exe.

Gamebar recording is disabled yeah?
 

bbacker26

Reputable
Dec 26, 2017
17
0
4,510
0
EDIT: I FIXED THE STUTTERING!!! FINALLY!! What I did that removed all stuttering was a combination of things so bare with me here: a fresh install of windows, unplugged the USB 3.0 cable from my motherboard, set my XMP profile to on and chose the "XMP 2" option in ASUS bios, changed my fps limit on my 165hz monitor from 162 to 163 in Nvidia control panel under "Max Framerate" (this seemed to be a more stable limit for some bizarre reason), completely uninstalled MSI Afterburner and Rivatuner as these introduced stuttering for me, Turned GPU Scheduling in Windows settings, turned on high performance power mode, turned off xbox game mode/dvr, and I also disabled all background apps in settings. The difference is night and day. Been dealing with stuttering for 4 months on my new 2k dollar pc and I can FINALLY enjoy it! There is literally 0 stutter now. PLEASE, if my situation is similar to yours, try out these steps. I suggest trying some of the less extreme stuff first (setting fps limit to 163, turning on XMP 2) before going ahead with a fresh windows install. The smaller things might actually be the issue. Please lmk if they helped you!
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS