Question Sudden "Boot Device not found.." - Installed Windows 10 on new SSD - Legacy disabled ?

Dec 1, 2022
2
0
10
0
It is a factory Windows-installed laptop. HP Elitebook 840 G4

Got installed a new WD SSD, installed Windows 10 (legacy off). Now while working - In every 1 to 3 hours suddenly after black screen boot error appears:
"Boot Device not found. Please install an operating system on your hard disk. Hard disk (3F0) F2 system Diag..". On restarting, Windows boots normally.

Please help with this.

Windows 10 USB media created with latest downloaded microsoft tool. Turning off legacy as I think latest windows 10 and UEFI install will be good that way.

Boot error screenshot
 
Dec 1, 2022
2
0
10
0
Welcome to the forums, newcomer!

Did you make sure you were on the latest BIOS version prior to installing the OS? What SSD did you have with the laptop and what did you swap it out for?
Thanks for the response. I appreciate the help.
- No, I updated the BIOS after Windows 10 installation with HP support assistant. After posting this question, I installed Windows 11 (legacy off - default, USB from ms tool) after deleting, creating drives to see if issue persists with different OS. While installing drivers, I found another new BIOS version has released a few days ago - so updated it. But again after half of the day of usage, the same bootdevice not found error (this time after BSOD) occured 3 times in span of an hour.
For fresh windows installation with already-latest BIOS - I installed Windows 10 again. This time, I installed only essential drivers, used the laptop without installing any softwares. But second day - same "bootdevice not.." [redacted].
  • The laptop is an used one (seems very-good condition) I bought from a known vendor, he had replaced HDD with a new WD Green SSD. This laptop comes without an optical drive.
  • Now what is weird is that this is the second laptop from him, I had replaced the first one (exact same model) with this as it had this exact same issue.
 
Last edited by a moderator:

Lutfij

Titan
Moderator
Please watch the language you use across the forums.

You're working with a refurbished laptop? One where it was used by someone(or some establishment) else prior to you? If so, then you might very well have a laptop that has a bug/glitch in it. Often times refurbished units come bundled with a problem or issue that most people can't identify or either experience on a day to day basis. Where are you sourcing the installers for your OS?

Make and models to both storage drives?
 
Got installed a new WD SSD, installed Windows 10 (legacy off). Now while working - In every 1 to 3 hours suddenly after black screen boot error appears:
"Boot Device not found. Please install an operating system on your hard disk. Hard disk (3F0) F2 system Diag..". On restarting, Windows boots normally.
Diagnose the SSD with manufacturer SSD tool.
Seems like a bad/failing drive or improperly installed (bad contact).

he had replaced HDD with a new WD Green SSD.
WD green SSD is ultra low end. I'd get something better.
 

ASK THE COMMUNITY