• Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Question Sudden fps Drop in all games and/or Stuttering

Aug 24, 2019
8
0
10
0
Hey Guys So I've recently Got this Problem I've been struggling to Solve

I Have 2 gpus
Nvidia mx130 4gb gddr5
Intel HD Graphics Uhd620
My Laptop Is not even 1 Month old yet
I'm making sure It doesn't heat and Both cpu and Gpu temperatures are FINE
I have tried restarting
Disabling game dvr in the registry
Lowering the Graphics in the game
Installing different Driver Versions
Disabling and Enabling the GPU
Checking for Viruses and malware with Malwarebytes avast etc
Adjusting the Right settings in the Nvidia Control panel so that It gives me the Best performance
Rolling back and Uninstalling updates (Windows 10)


The video games were all working Fine and All of a sudden this happened
my mx130 runs Minecraft in 15 fps
I used to run megaman 11 Solid 60 fps even in Difficult Conditions and now it jumps from 30 to 60 While plugged in and 30 and rarely Jumps to 60 on Battery
while it was solid 60 fps on both Conditions
My integrated gpu Runs it much better than that
How Can I solve this problem?
Laptop specs:
16 GB ram ddr4 2300mhz 8565U 1.8 GHz boosted to 2.00 GHz
1 TB HDD seagate
Intel core i7
Nvidia mx130 4gb
 

iiSlashr

Great
Mar 10, 2019
139
12
95
2
OK, I would recommend trying a clean install of Windows and perhaps considering the possibility that you may want to get a PC instead of a laptop. If you are deadset on using that laptop, and the integrated graphics work better as you say, just use those.
 
Aug 24, 2019
8
0
10
0
OK, I would recommend trying a clean install of Windows and perhaps considering the possibility that you may want to get a PC instead of a laptop. If you are deadset on using that laptop, and the integrated graphics work better as you say, just use those.
I have an original copy of windows 10
however, I think I might downgrade to windows 7 But I'm not sure If that's a good decision
I really can't get a pc Since I move around and travel a lot
 
Aug 24, 2019
2
0
10
0
Just leaving a reply so i can find this tread later

Man, i have very similiar problem.

HP laptop; Specs:
AMD Ryzen 3 2200U 2500 MHz/15.6"/1366x768/8GB RAM/AMD Radeon 530/Windows 10 Home

Abot after 2 or 3 months after i bought my laptop, bumped into a problem. As you can see, there is a hybrid system of AMD Radeon Vega 3 and Radeon 530. In some applications (games mostly), which use R 530 card as a main GPU, a strange thing happens: the total perfomance of the card drops to very low values on absolute random basis (WIN 10 task manager shows that it falls from 80-100% usage to 15-20%), and so the FPS drops. And after a week or two after appearance of that perfomance-drops, happend my first BSOD.

Figured out (found people in the NET with similiar problems) that the GPU automatically overcloking for better perfomance, but have serious problems with swiching back to normal (From 3D compute to 2D especially. Its enough to just Alt-Tab to desktop to get a BSOD), which results in BSOD's with "Thread stuck in device driver" with problems in "atikmdag.sys" and "dxgkrnl.sys".

Hope you can find a solution for you, so I can try it, since i've triad almost all things so far:
Tried to reinstall Video driver, installing older/newer versions, updated BIOS.
Still no result.
 
Aug 24, 2019
8
0
10
0
Simply go into an app like MSI Afterburner and set your GPU core clock to -100
I've made a fresh Install of windows
and there's Still fps drop
Temperature is Fine tho
It's impossible that it could be a Hardware problem since the laptop Is less than a month old
 
Aug 24, 2019
8
0
10
0
stick with 1 thread
Alright I have a low-midrange nvidia gpu (mx130) this problem popped up recently

I Used the msi afterburner benchmarks to watch the stats of my gpu cpu and ram
the temps of Both the cpu and gpu is Normal (60 Celsius)
ram Usage is lower than 4 gb (16 gb)

Well When I'm playing the game Cpu usage is only 10% (Cpu usage is 10% while the game uses 9% in task manager while the msi says its 40% idk why) and the gpu is 60%
When the fps drop happens it drops to 40% then Jumps back to 60% when the fps goes back to Normal
When I disconnect the laptop charger however It stays below 35

Strangely When I connect the charger for a short period of time and disconnect it
It jumps back to a solid 60 and Drops to 35 later on
the gpu starts at very high usage (above 85%) however It must provide high fps with that usage but It's still low then it drops to 60% with the same fps.

When I connect the charger the game goes back to Normal But some stutters could happen still
I was playing this game Just totally fine with High settings at 60 fps solid with only aa and vsync off in both cases (while the laptop is charging and While it doesn't)

I have downloaded MSI afterburner and nvidia Inspector and tried to Overclock and underclock the gpu
Tried changing the core clock either by decreasing or increasing it same goes for the memory clock and the voltage. When I do that it does very Little to no effect on the game despite dramatically changing them
This Is a stalemate

I tried setting the power plan to high performance
Changing nvidia settings to provide the best Performance
Uninstalling Update reinstalling Windows Updating the driver and rolling back to Older versions disabling and Enabling the gpu etc

My laptop specs
16 gb ddr4 2300mhz
nvidia mx130 gpu 4gb vram gddr5
Intel core i7 8565U quad core 1.8 ghz boosted to 2.0 ghz
1 tb HDD
 
Last edited by a moderator:
Aug 24, 2019
8
0
10
0
My Gpu was running totally Fine
It's Temps are actually Good
(50-70 Celsius) same for the cpu
Laptop specs:
16 GB ram ddr4 2300mhz
intel core i7 8565U 1.8 GHz 1.99 GHZ
1 TB HDD seagate
Intel core i7
Nvidia mx130 4gb gddr5
All games were Running fine But all of a sudden It's Just terribly Dropped
Even Old Outdated games could have an fps drop
(Happened to me in a 1998 video game......)
I tried updating to the latest Driver
Reverting to Old drivers
Downloading Drivers from the Laptop Manufacturer "hp" Website (I Uninstalled the Nvidia gpu Drivers with DDU)
the Laptop Is in high Performance
the nvidia Cp Is well Optimized
Uninstalled Nvidia geforce
updated BIOS
Reverted to Old Windows 10 versions and even reinstalled it
Both cpu and Gpu Temps are totally Normal
I have Disabled GAME dvr Both in Settings and in Registry Editor
Still No result
I have Monitored the game with Msi afterburner
Sometimes the gpu runs the game 60% (Which gives solid 60 fps) and When it drops to 30 fps the Gpu load drops to 30-40% Usage
Please Help me Fix this Issue
 

ASK THE COMMUNITY

TRENDING THREADS