Question Sudden Frame drops. Any solution?

Aug 16, 2019
3
0
10
0
Hello Guys,

Few years ago I did build my first PC setup and since I have putted everything toghether installed windows 10 OS and run first game im experiencing sudden frame drops from let's say 60fps to 1 fps and it takes around 1 or 2 seconds to get back to solid 60. It is also followed by sound glitches. (It happens too often so i can't take any fun from playing games)

This problem is most intense during multiplayer sessions with other players through internet or lan,

I am not surprised that my PC can't hold FPS in latests games such as BF 5 or let's say APEX LEGENDS. But it is wierd because it happens in any old games such as Age of empires (Multiplayer) or NFS Underground.

Sometimes when I am playing games screen just go's black for few seconds and after that game crashes and everything going back to normal (Problem with those black screens likes to happen also during tasks such as web browsing or just simply sorting out stuff on desktop)

During past 2 years I am trying to solve my problem, I even created post on one of the PC forums (don't remember which one exacly) and followed all suggestions.

There is list of stuff I did to try fixing my PC:

  • Installing and updating all drivers including chipset and graphic card drivers (Latest Invidia drivers made it even worst)
  • Reinstalling operating system (made no difference)
  • Overclocking CPU Using settings in MSI GAMING APP (I did it last week)
  • I sent PC for full diagnostic to specialist (Havn't find any Hardware problems)
  • I had suggestion that all of those issues are caused by PSU so i replaced it with corsair rm1000i as it was recommended (Absolutly no difference in gaming preformances)
  • I did HDD Disc diagnostic and defragmentation (It seems like it is in good condition)
With that being said I have no idea what else I can do to sort the problem out. I run out of ideas and have no clue what to do next.

MY SPEC'S:
WINDOWS 10 OS
MSI GTX 1050ti 4GB
MSI X370 (Motherboard)
AMD Ryzen 5 2600X
HyperX HX430C15PB3/8 Predator DDR4 8 GB, 3000 MHz
corsair rm1000i (PSU)
120GB SSD Drive (for system only)
1TB HDD Drive

Sorry for my english and thanks for help
 
Aug 16, 2019
3
0
10
0
I followed your advise however it didin't help. Im just wondering. Could it be issue with ram at some point? It could be lack of knowlage but i heard from someone that not all rams are compatible with motherboard im currently using. But even if i just simply got wrong ram i don't know how would it affect overall preformances or if the system would start at all.
 

ASK THE COMMUNITY

TRENDING THREADS