Sudden, huge lag playing World of Warcraft only

Status
Not open for further replies.

Cylistarr

Prominent
Apr 24, 2017
5
0
510
0
I don't know how to remove this so I'm editing; I found a solution, no further action is needed.

My husband and I play World of Warcraft and ever since just under two weeks we both get such massive world latency that it makes the game unplayable. It happens constantly when we play, no matter whether we play at the same time or not. Some times are better than others but the spikes are consistent and occasionally so bad that it takes minutes for everything to catch up.

Not only that, but neither of us is able to reliably load any Blizzard page of any kind using any browser. I can't go to the forums because I can't load them. Basically everything related to Blizzard games lags so bad that we can't use it. This has never happened before.

We both use desktops we built, his runs Windows 10, mine runs Windows 7; we both use Nvidia. We are Ethernet connected to the router (it's only a few months old) and have no problems with anything else. Speed tests come out perfectly.

We have tried everything we can think of but it doesn't make sense that Blizzard..everything is the only thing we have huge latency with, and it's both of us.

If anyone has ideas we would appreciate it. Not really ready to give the game up yet, but the way it's going we may not have a choice if something doesn't change.
Thanks.

I don't know how to remove this so I'm editing; I found a solution, no further action is needed.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS

Latest posts