Question Sudden performance loss.

Jul 24, 2021
3
0
10
0
I don't know if anyone can help me figure out what's happening. Last Monday i noticed that my pc performance was not what it used to be best way i could describe it would be like trying to play a game on a gaming laptop that's not plugged to its charger so sluggish and not getting the right frames and just generally wonky. PC boots and runs and i can still do stuff. I had bought a new PSU thinking it was maybe power related and that didn't fix my problem. I changed GPU's on my rig and that didn't change anything also tried my current one on a friends pc just to double check and its working fine. Friend of mine suggested that it could be the Mobo but I'm not sure if it is. Any ideas?

Mobo: Asrock B550M/ac
RAM: 16 GB 3600 MHz
CPU: Ryzen 7 3700x
GPU: Zotac 3070
PSU: 650 wats but did buy a 750 (will probably return it)
 
Jul 24, 2021
3
0
10
0
what power supply?

make sure you are using the High Performance power plan and that is has not been altered somehow.
It is on high performance and the 650 is from gamdias kratos (as far as I can tell is working fine since replacing it didn’t fix anything) and the new one is a Corsair RM750
 
Jul 24, 2021
3
0
10
0
if you have verified the High Performance power plan hasn't been altered

load BIOS optimized defaults,
re-enable XMP profile

scan drives with Chkdisk

test memory with Memtest

run SFC in Windows to verify system files integrity
The issue was with my mobo. Went out and bought a new one earlier and its back to normal no more problems. Thank you for trying to help 🙏.
 

ASK THE COMMUNITY

TRENDING THREADS