switch from ide to ahci windows 10

Status
Not open for further replies.
Sep 12, 2015
66
0
4,630
0
Hi,
My bios was set to IDE mode for my SSD when I installed windows 10. Now I want to switch it to AHCI but when I do that in the bios, windows 10 doesn't boot. I know there is some registry fix for windows 7 and 8 but how about windows 10?
 

lonewolf7

Splendid
Moderator
Yes there is a way on WIN 10 also ! Go into BIOS set the SATA mode to IDE and boot into system.

Start REGEDIT and look for this line :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride

Change the 0 DWORD value from 3 to 0.

Reboot, and change your SATA controller to AHCI in BIOS. Now let it boot into safe mode, WIN 10 will install required drivers for AHCI.

Now with a normal boot you will boot into Windows with AHCI drivers.

Note : OEMs suggest reinstalling rather than changing, especially with an SSD.

You stand the chance of loosing your install if something goes wrong, and different systems may behave differently.

Not Recommended for Windows 7.
 

TeachMePls

Reputable
Dec 31, 2015
1
0
4,510
0

Thankyou, read your post just in time before adding apps to my new installation, Now re-installed in AHCI , Great post!
 

anirban67

Reputable
Jan 5, 2016
2
0
4,510
0


 

Wayfall

Honorable
Dec 27, 2013
3,467
0
13,460
373
(I'm looking at this link as it was posted in this thread:http://www.tomshardware.co.uk/answers/id-2995637/ide-ahci-warning-bios.html)

I got an SSD a while ago and installed windows 7 on it but did not know about AHCI as when I loaded up Samsung Magician it said it was not disabled and need to be to allow all the SSD's functions to work correctly.

So I looked online and found a Youtube video showing me how to change the code then go into BIOS and change to AHCI.
Kind of annoying I have been a happy owner off an SSD for over a month now and its brilliant, pc loads up in under 10 seconds.
 

sayginates1989

Commendable
Apr 19, 2016
1
0
1,510
0


You are the best!Thousand times thanks you my man.You are awesome.
 

Wayfall

Honorable
Dec 27, 2013
3,467
0
13,460
373


I have Windows 7 Home Premium OEM and I changed to AHCI in Windows Regedit and then BIOS while the OS was installed and I was totally fine. Its totally safe on Windows 7
 

K K0

Honorable
Jul 15, 2012
283
0
10,780
0


Thank you very much for posting this it worked perfectly for me. One question that probably stems from my slight OCD but assuming everything went fine (which it did) would someone still be better off still reinstalling windows? I mean it seemed like a pretty straight forward fix i shouldn't run into any weird issues down the road right?
 

murlok

Distinguished
Sep 14, 2007
3
0
18,510
0


 

aledjones

Commendable
Aug 11, 2016
1
0
1,510
0
I'm having exactly the same problem. SSD only boots windows 10 when set to IDE in the BIOS. I've tried running the regedit fix above and setting data value to 0, rebooting, changing BIOS to AHCI - but when I reboot just get the blinking cursor again and have to reboot after switching back to IDE to get Windows to run.....

Anyone know any other fixes for getting your windows install to recognise AHCI rather than IDE, without completely wiping the SSD and re-installing windows? Can do that but I've got a lot of time and important docs on the SSD....
 

David_426

Commendable
Aug 19, 2016
1
0
1,510
0
I dont know why but for me, the dword value wont save after reboot, the 3 value come back each time, what to do?




 

Laurentiu Larry

Honorable
Dec 11, 2013
6
0
10,510
0


i somehow managed to make it work in an earlier redstone build but in the last 3 months or so it stopped working and it has the same symptoms... which kinda sucks..
 

Konstantinos_5

Commendable
Sep 26, 2016
1
0
1,510
0



How can i go into safe mode?

 
Status
Not open for further replies.

Similar threads


TRENDING THREADS