Question Switched PEG to IGD, no display in BIOS and Win 7!

Aug 18, 2022
7
0
10
0
I have a Win 7 - Win 8.1 dual boot PC.

After I switched PEG to IGD inside the BIOS settings, nothings displays in the BIOS screen and Win 7 anymore but Win 8.1 and the "Choose an operating system" screen are still displaying.

I did this because I noticed that Win 7 had only 2.23GB usable RAM out of 4GB. I applied all the possible fixes I found but none worked and this was the last option.

I'm quite sure that this has fixed the RAM problem since I also had a similar issue in Win 8.1. It's former ~10GB usable RAM out of 12GB has increased to 11.9GB

Relatable specs
CPU: Core i5-7500
GPU: GTX 1060 6GB
RAM: 12GB / 3x 4GB sticks - Not the correct RAM configuration, I know... never had any issue with it though.
Mobo: B250M PRO-VDH (MS-7A70) - Latest BIOS version A.80, installed with MSI Live Update 6
1st installed OS: Windows 7 Ultimate SP1 x86 - All available updates were installed
2nd installed OS: Windows 8.1 Enterprise x64 - All available updates were installed
Monitor: LG 25UM64 - Connected to the GPU with HDMI cable

Could anyone give a solution please? Thanks in advance!
 
Last edited:
After I switched PEG to IGD inside the BIOS settings, nothings displays in the BIOS screen and Win 7 anymore but Win 8.1 and the "Choose an operating system" screen are still displaying.
I did this because I noticed that Win 7 had only 2.23GB usable RAM out of 4GB. I applied all the possible fixes I found but none worked and this was the last option.
Connect monitor to video output on motherboard.
Then get into BIOS and disable integrated GPU (and turn off multi monitor feature). Save BIOS settings and reboot.
Reconnect monitor to graphics card.

Your windows 7 is detecting 2.23GB of ram, because it is 32bit version of windows 7.
To get more ram accessible, you'd have to reinstall windows 7 64bit (clean install).
 
Aug 18, 2022
7
0
10
0
Connect monitor to video output on motherboard.
Then get into BIOS and disable integrated GPU (and turn off multi monitor feature). Save BIOS settings and reboot.
Reconnect monitor to graphics card.

Your windows 7 is detecting 2.23GB of ram, because it is 32bit version of windows 7.
To get more ram accessible, you'd have to reinstall windows 7 64bit (clean install).
I did that before, nothing showed up.
Reconnecting didn't work neither.
I even tried going to the BIOS with no screen on and just use the movement and Enter keys to change IGD back to PEG, again, nothing happened.
I need Win 7 x86 to play old games that are not compatible with any Win release that came after it.
As far as I know x86 systems support a maximum of 4GB RAM so I shouldn't get just 2.23GB...
 
Last edited:
Aug 18, 2022
7
0
10
0
don't think you can get licence for enterprise on a local store.

could be malware on your os
Umm... I'm not sure about the Enterprise license thing (I'm not in America btw) I've checked the System Properties in Control Panel before and it says "Windows is activated". Same goes for Win 7. Didn't notice anything weird.

I also remember running DISM and SFC scans on both of them. No corrupted or modified files were found.

Both systems were working just fine before I changed PEG to IGD. I haven't visited any shady sites nor run suspicious files neither. I don't think it's a malware..
 
Aug 18, 2022
7
0
10
0
Oh well.. I'll go get an AV then >.<
Good thing I still have Win 8.1 working

Lets see how resetting the BIOS goes..
 
Aug 18, 2022
7
0
10
0
Update: So according to the manual in the link there are two ways to reset the BIOS
Press F6 inside it to load "optimized" settings, which didn't work, obviously..
or use a CMOS jumper cap to short it, which is something that I couldn't find inside the mobo's box :|
I looked for other methods in Google and removed the CMOS battery instead - and it worked
Everything's back as it was before - including Win 7's 2.23GB usable RAM :/ here's a pic of how it looks like
Can anyone give a solution for this?!
About the malware thing - haven't got an AV yet..
 

ASK THE COMMUNITY

TRENDING THREADS