Question System Freezing After Changing RAM Settings

LordHolmezy

Prominent
Aug 1, 2017
13
0
510
0
I recently installed 32gb of Corsair Vengeance RGB PRO ram into an x370 Gaming Pro from MSI. I was tweaking the RAM to run at the highest speed regardless of latency, (I believe I had c18 before problems started happening). when I booted windows up again the system would freeze for 20-30 seconds and briefly start working again, this repeats. The CPU and GPU weren't under load and I have a sufficient psu of 700w. I have reset my ssd and installed windows again, removed hdd, switched out ram, changed speed to default etc. BIOS is up to date

Here are my system specs:
MSI Gaming Pro x370
RTX 2070 Founders Edition
Ryzen 7 2700x
32gb Corsair Vengenace RGB PRO C16
256gb Samsung Evo Pro 970
1tb Seagate Ironwolfe @ 7200rpm
Thermaltake White 700w
 

LordHolmezy

Prominent
Aug 1, 2017
13
0
510
0
Than it must be a BIOS restriction, 2700x is capable of 4000MHz , my RAM is running at 3600MHz Cl16 without any trouble. Do you have latest BIOS installed, there were a lot of changes lately ?
I did install a file from BIOS to help with higher RAM timings, it seemed like a precursor to what happened with my build. But Im starting to think there might not be enough thermal paste on my cpu since i swapped it out with another one.

UPDATE: I can now log into my account and the freezing doesn't require a restart. There is still a lot of stuttering and short freezing, the display turns on and off going into task manager.
 

ASK THE COMMUNITY

TRENDING THREADS