Question System no longer POSTs ?

Jul 8, 2022
2
0
10
0
Good morning/afternoon/evening everyone,

Earlier today I installed some new components to my existing PC: changing the RAM, PSU, and GPU. I had gotten everything working as intended and after 1-2 hours the system was no longer functional.

On hitting the power button, the system will light up for a split-second, with fans starting to turn, then the system shuts back down.

The on-board LED lists no error message, and the status LED for the CPU turns red then terminates.

Here's all I've tried so far:
  • Reseating RAM / GPU / all power connections, both into the MOBO and from the PSU
  • Removed all components until only the CPU, heatsink, and MOBO were installed & powered.
  • Reseated CPU & cooling
  • Tested different memory configurations using a variety of known working RAM
  • Worked my way through the pinned thread on No POST system troubleshooting checklist
While this thread sits I'll try a different PSU, and then anything else that comes to mind, but if you all have any ideas or need any other info from my end, it would be appreciated.

CPU: Intel i9 9900k (Age - 2 yrs.), with Corsair H150i Cooling (1 yr.)
Motherboard: GIGABYTE Aorus Z390 Ultra (Age - 2 yrs.)
Ram: (4) Corsair Vengeance LPX DDR4, 16GB ea., 3200MHz (New), previously G.Skill Trident 4x8G 3200MHz
SSD/HDD: (2) Samsung 970 EVO NVMe M.2 (2 yrs.)
GPU: EVGA NVIDIA GeForce 3080 Ti (New), previously GIGABYTE NVIDIA 2070 Super
PSU:ROG Thor 1200W Platinum (New), previously Corsair 850W Gold?
Chassis: Unsure, Deep Cool Mid-ATX (2 yrs.)
OS: Windows 10 Home
Monitor: (2) Acer XFA240 (2 yrs)
 
Jul 8, 2022
2
0
10
0
Update:
Tested CPU / heatsink / MOBO with a different PSU to better results. Added 16GB memory as above, resulted in stable POST. However, the PSU used to test is a smaller 650W unit so I don't think I can test the full system yet. On an only slightly related topic, if anyone passes by and has a PSU that they could recommend for the system specs in the OP, that would be nice as well.
 

Cyberat_88

Distinguished
Apr 9, 2011
1,774
35
19,890
49
Corsair 850W Gold is just fine. Never heard of ROG in the PSU business...
You must be able to run bare posts stable, nothing connected, then run memtest x64 once you do that.
I assume you reset your Bios and re-optimized it.
 

ASK THE COMMUNITY