Question System no POST, no signal, no beeps.. dead board?

dave.d.mclellan

Commendable
Mar 31, 2018
8
0
1,510
0
Hello,

I recently purchased a used Asus B85-M board, and had the system running straight after installation for 3 days with no issues.

On the fourth day the system will no longer display a signal, no post, and no beeps from the system speaker.

The motherboard LED remains solid green at all times while power is on.

All fans are spinning.

I have gone through the guide on this forum thoroughly to be sure it wasn't something simple, but I am stumped.

When I first received the board, my i5-4670 booted with no BIOS update, but I needed to update to the latest BIOS in order for the i7-4770 to boot.

I originally had an RX550 in the system while it was working, but tried using another known working GTX1050Ti with no success.

Resetting BIOS in an attempt to use the onboard graphics also did not work with either CPU.

I have tried each RAM stick individually - all were taken from a different working system.

I have also removed anything unnecessary from the board - only have power switch, board power, cpu power, and cpu fan, system speaker connected.

I suspect the board has coincidentally died after only a few days usage. Thoughts?

System Specs:
Board: Asus KCC-REM-MSQ-B85-M socket LGA1150

CPU: i7-4770 / i5-4670

Cooler: Arctic Alpine 12 LP

RAM: 16GB (4x4) Kingston 1600mhz DDR3

PSU: Silverstone TX300 300W

GPU: RX550 4GB / GTX1050Ti 4GB

I appreciate any suggestions and help. Thank you.
 
Last edited:

ASK THE COMMUNITY