Question System Power LED Blinks after shutdown, both online suggestions seem to be incorrect.

Hunted98

Honorable
Jan 23, 2015
8
0
10,510
0
Last night my case's power LED started Blinking after shutdown. The internet suggests that this can often indicate a power supply issue, while my motherboard manufacture handbook says that the only case for the power LED blinking is s3 sleep state. I'll address each of these why I feel it can't be either of them below.

1) Power Supply Issue:
This one seems unlikely because there haven't been any other performance issues. I can still play games that pin my GPU and have no stutters, black screens, or crashes. There haven't been any indications that there is physical damage to the PSU either

2) System going to sleep state s3:
When I issue a shutdown order to windows the Power LED Blinks, which MOBO manual says means s3 sleep state. This is not the state my system is in because I cannot wake back up via a USB device. I also see a full post screen when I hit the power button again, which per my research so far, indicates that the system was not in s3 either.

3) Other Ideas seen already:
I saw some threads suggesting a broken/shorting Power Button/LED but the behavior described there is different enough I don't think it applies.

Are there other reasons a system will flash that power LED? If it is the PSU then how is it even detecting an issue if I am facing no issues with the system? The PSU is still under warranty but I don't want to start an RMA if there are other options.

System Specs:
Fractal Design Nano S Case
Ryzen 5 1600 (w/ aftermarket Cryorig Cooler)
EVGA 1070 Superclocked
ASRock Mini-ITX Motherboard - AB350 Gaming wifi
16 GB G-Skill RAM 3200Mhz
EVGA 500 BQ PSU
128 GB Kingston SSD
4TB Seagate HDD
 

Crowii

Honorable
Dec 28, 2014
82
15
10,565
7
1)
Doesn't necessarily mean a super duper serious issue; it would just be reporting that there's something it doesn't like about the power delivery. You could borrow a spare known good PSU, with known good cables, and try it out with that instead.

But it's a single LED that is maybe giving off a distress call, with no further context. Can't really figure out why it's saying ''its broke, I don't like it'' without just trial & error everything.

2)
Just for fun, have you tried shift+shut down to get it into S5 (off state/full shutdown)?
If this helps, disable fast startup in power options in windows.

Have you updated to the latest version of Windows? (Slightly related to fast startup LED issue)

Have you tried unplugging the HDD activity LED? (I'm not sure how or why this would show this behavior, but might as well. Can't really distinguish the PLED and HDDLED on the Fractal Design cases since they're right beside each other.)

Other than that, the good ol' replug all cables.
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS