System Refuses to Load Windows - Bad SATA Controller?

Nov 11, 2018
2
0
10
Apologies in advance for the length, but I've been at this for about a week so far and wanted to save everyone some time by outlining the steps that I've already taken. I'll try to organize it as best I can to make reading easier.

TL;DR: My system refuses to boot into Windows after a motherboard replacement regardless of which drives, ports, or cables are used. I think it's possibly a bad SATA controller, does anyone have a way to test for this?

Background:
About a month ago the gaming desktop I assembled four years ago died, and after a few days of troubleshooting I zeroed in on motherboard failure (Maximus VII Hero) as the most likely culprit. This wasn't itself a huge issue since I was planning to replace it with an ITX board and shrink the whole thing down to fit into the ITX tray of the new Phanteks Evolv X case and build a new full ATX system in there to replace it.

So I ordered a used ITX motherboard through Amazon (new ITX motherboards for 4th gen Intel chips are hard to find or extremely expensive), the new Evolv X case, and the Revolt X PSU I would need to run the dual system configuration and assembled it with the surviving components from the old rig. The ITX bracket was out of stock so right now the motherboard is just mounted in the primary motherboard space.

I tested the new configuration both with the old PSU and then the new PSU after it arrived and the system was generally passing basic tests (it would boot into Windows). I was planning to wipe and reinstall Windows onto the boot SSD to eliminate any residual driver issues that might crop up from the hardware change.

The Problem:
I attempted to wipe the boot drive and install Windows 10 from a USB stick but each time after finishing the installation, Windows 10 would refuse to boot properly. I got repeated "it looks like Windows didn't load correctly" messages asking me to restart, but each restart would inevitably lead to the same result. I tried reinstalling Windows again but got the same results each time.

I moved the system back out to my living room to test it with a few other SSDs I pulled from an old desktop. The first one had an existing Windows 10 install and booted just fine. I installed a fresh copy of Windows 10 on the other and it too worked just fine. So I plugged the original boot SSD back in and lo and behold, it too worked just fine. I also removed all unnecessary hardware (all of the extra hard drives and the GPU) for that test, before plugging it all back in for a final test. Everything seemed to be working properly, so I put it back in my bedroom where it normally belongs.

Which is when the same problems started cropping up again. Windows would refuse to load properly most of the time. Sometimes it would reach the login screen but would hang after I put in my PIN. Occasionally I'd get lucky and reach the desktop itself but I'd get more system slowdowns and the system would turn itself off after a few minutes. Sometimes I just wouldn't get anything after getting past the BIOS, and the system would just shut down.

And that's where I am at present: the system refuses to boot into Windows most of the time, and the few times I can get to the login screen in Windows it either freezes trying to log in or shuts down shortly after getting to the desktop, with poor responsiveness along the way. At first things worked fine, but now I cannot get into Windows at all.

UPDATE: During a test boot while writing this description, I got a BSOD just after inputting my PIN into Windows 10 that gave me the "DRIVER IRQL_LESS_OR_NOT_EQUAL" error pointing to storahci.sys. I got that a few times before I wiped the drive, but not in testing before I returned the desktop to my bedroom. During a later test while trying some additional troubleshooting for the sake of thoroughness, I got a "CRITICAL_PROCESS_DIED" BSOD.

My Hypothesis:
My guess at the moment is possibly a bad SATA controller, or some other issue with the motherboard. While the system POSTs every time and I can get into the UEFI without any problems to make system changes, currently the system will fail to load Windows from any drive and from any SATA port. If manually directed to boot from the recovery USB however it works every time and I can usually Windows without problems.

My guess is currently reinforced by the fact that in the few times I've been able to get it to load into Windows (before shutting down), one of the four drives that is connected to the system does not appear. Also, both BSODs are related to storage issues from what I can tell, but are NOT limited to a specific drive; all three SSDs I've tried fail to load Windows and I can't even get into Windows to check the event log or update Intel RST.

So the money question: Does anyone have any alternative hypotheses or tests to run to confirm or disprove this hypothesis?

Solutions attempted so far:

    Checked the cables, connections, and mounts. I've checked the SATA power and data cables as well as their connections to the drive, motherboard, and PSU. I've also swapped out the SATA power and data cables for testing and tested different motherboard SATA ports. This includes checking the RAM seating and all other cabling. The few times I've been able to get the system to boot into Windows, three of the four drives that are connected are visible to the system, which is why I suspect it might be a SATA controller issue. The front panel USB 3 ports also don't seem to work, which might indicate something else is wrong with the board as well.


    Checked the outlet, power strip, etc. I've tested the system with multiple outlets in my bedroom and with different power strips, including the strip that it booted with in my living room. The same problem occurs. The old desktop I pulled the SSDs from for testing was plugged into the same outlet and has no issues.


    Checked the drive itself. I've swapped in multiple different SSDs with copies of Windows loaded and all have the same problems loading Windows when the computer is in my bedroom. But all of them worked fine in the living room.


    Checked the PSU. The system booted with both the old PSU and the new PSU when tested in the living room.


    Reset the BIOS. I pulled the CMOS and reset the BIOS, and checked to make sure everything is up to date. It's running the most recent BIOS revision and the same errors are occurring.


Configuration:

  • Intel i7-4790k
    Gigabyte GA-H87N-WiFi Rev. 1
    NZXT Kraken X61 280 mm radiators (w/2x Corsair ML 140 fans)
    16 GB (2x8) G.Skill Trident X 2133 MHz (@1600 MHz since the GA-H87N doesn't support 2133)
    Crucial MX100 512 GB SSD
    Seagate Barracuda 3 TB HDD
    Seagate Barracuda 4 TB HDD
    Seagate Momentus 750 GB HDD (salvaged from an old laptop)
    Sapphire R9 290 4 GB Vapor-X
    Windows 10 Pro
    Phanteks Revolt X 1000 watt PSU
    Phanteks Evolv X case
 
F3-2133C9D-16GTX
Tested Speed 2133MHz
Tested Latency 9-11-11-31-2N
Tested Voltage 1.60v

What are the first four DRAM timings numbers starting with Cas Latency your running at now? What is current command rate?
I imagine DRAM voltage is still on [Auto].

 
Nov 11, 2018
2
0
10


Retail. The original SSD is using a Windows 8 upgrade key that was originally purchased for use on an OEM Windows 7 laptop but activated fine in the desktop years ago and reactivated fine after swapping out the motherboard.

One of the other SSDs used an off-the-shelf retail Windows 8 code upgraded to Windows 10.

The last SSD didn't get a separate code because I was only testing to see if I could boot into Windows at all, and at the time it could do so fine. But now it and the other drives cannot.



9-9-9-24-1 @ 1,333 MHz
Voltage is 1.5v

The BIOS reset turned off XMP which set the memory to 1,600 MHz and I haven't turned it back on. These are the default settings the BIOS is operating with after the reset.
 

ASK THE COMMUNITY

TRENDING THREADS