Question System restore no longer working

Aaron Wong

Honorable
Dec 9, 2013
9
0
10,510
0
My dad has this old PC that occasionally boots up with a black screen that does nothing on Windows 7 after the Windows loading screen.

I fix this normally by using system restore and everything is fine. This happens once every 1 or 2 months. But it happened again and this time system restore no longer works. Seemingly blocked by AVG and its "antiransomware". View: https://imgur.com/a/KQTrjYi


I've considered downloading a repair tool on the USB but i can't find the windows version from the system restore page since it boots through 'X' on the command prompt.

I'm wondering how i could solve either of those issues by either:

Resolving the issue with AVG blocking the system restore.

or

Finding the full windows version through system recovery (or any other method).

Thanks.
 

USAFRet

Titan
Moderator
Mar 16, 2013
114,625
2,129
157,290
18,659
Restore Points are only good if they were generated at a known good state.
A Restore Point made when the system was acting up would simply continue to act up.

I'd seriously consider a fresh OS install.
 

Aaron Wong

Honorable
Dec 9, 2013
9
0
10,510
0
Restore Points are only good if they were generated at a known good state.
A Restore Point made when the system was acting up would simply continue to act up.

I'd seriously consider a fresh OS install.
Do you know how to find the product key for Windows 7 from within the cmd prompt from the System Recovery? I need it to get an ISO file from the Microsoft website and it requires a product key that I don't have access to
 

onespeedbiker

Notable
Apr 13, 2019
1,120
65
890
25
You might as well disable AVS and try the restore again, if for no other reason than to get your Windows 7 COA. OTOH, if Windows 7 came preloaded on your PC, it's likely there is a sticker on the case.
 

ASK THE COMMUNITY

TRENDING THREADS