zorrohere

Reputable
Aug 22, 2017
27
0
4,530
0
I have an issue where when I connect my headphones to PC it starts feeding system sound to mic. So if I call someone from PC they can hear my system sound, even if I mute my headphones using physical button it doesn't stop feeding the sound.

On PC: If I start OBS studio and disable recording system sound. Mic recording is on but I turn off mic using physical button on headphones. System audio is still fed into mic channel and gets picked up by OBS. It only stops if I unplug headphones. I have tested two headphones andboth behave same, right now I am using Razer Kraken with 3.5mm jack. My onboard sound card has stopped working and I have two USB sound card, both behave same. (One is cheap non-branded and other one is Sabrent)

On Mobile: I tested on Asus Zenfone Max Pro M1, it feeds mobile sound into mic but Mi mobile doesn't feed system audio into mic.

So it seems issue with my mobile and PC rather than issue with headphones or sound card. I believe many people must have faced this issue, any settings I can tweak on PC to disable this behavior? Would be great if there is solution for mobile as well.
 

dudeawsomeness1

Honorable
Jul 8, 2015
37
0
10,540
1
My friend is having the same problem, are you using a splitter by any chance? I'm just wondering, I don't know how a splitter could possibly cause these issues. I remember a time when he didn't have this problem, but I'm not sure what changed. What confuses me more is that you also have this problem with your phone. I've also tried my headphones with it yet no change.
My friend already had this disabled, but have you disabled "Stereo mix"? Right click on the speaker icon on the taskbar, go into "Sounds", "Recording" tab, and check if "Stereo mix" shows up.
 

ASK THE COMMUNITY