Question System unable to boot after two days of MSI x370 krait gaming BIOS update.

Jun 3, 2020
1
0
10
0
So this all started with installing a m. 2 SSD. My system was working smooth for last 2 and a half years. I had:

msi x370 krait gaming mobo
ryzen 5 1600 cpu
gtx 1060 3gb
adata xpg spectrix 8gb 3000 (16) ram,
1tb hdd


So then i installed adata xpg spectrix 256gb m.2 ssd and things started to change. First mi ram rgb stopped. For which i tried reinstalling th rgb softwares, that didn't work. Then changed the ram slots, that too didn't work. Then i decided to update my bios. As everything was fine except the rgb, i thought of giving the latest beta update of the bios a try. Did that, but thats when things started to get messy.

Now after the bios update my msi gaming app won't open, xpg rgb app won't open. In the mean time i got my new adata xpg spectrix 16gb 3200 8x2 dual channel ram module which replaced the old one. Now the ram rgb are glowing but i can't control them.

Ok but now much more serious issue started after a day, the system started to flicker, if i connect or disconnect something my pc will freez. I tried resetting my windows, that worked for the time being. This was yesterday, now today, the whole system won't start.

P. S- in the mean time i tried to go back to the latest stable bios version but mflash can't detect any bios file in my usb drive.

Please help anyone.
 

ASK THE COMMUNITY

TRENDING THREADS