System Under Performing

G

Guest

Guest
Hi,
I've recently pruchased a PC for gaming and casual application work.
The main game i play atm is Counter Strike Source After installing all the latest drivers and the game i loaded it up, Jumped into a server and found myself playin at 40 FPS ( i was expecting alot more). I was instantly concerned and tryed to improve it, and i was still only gettin 50 FPS on lowest settings. I am worried that there is a Hardware Coflict or BottleNecking of some sort.
Any help would be much appreciated.

Specs:

CPU: Intel® Core 2 Quad Q8400
CPU Cooler: Coolermaster Hyper TX2
Motherboard: Asus P5N-D (nForce 750i chipset, SLI)
Memory: 4.0GB Corsair DDR2 800mhz XMS2
Hard Drives: 250GB S-ATAII 3.0Gb/s
Optical Drive: 20x DVD±RW DL
Graphics card: ATI Radeon HD 4850 512MB
Sound card: Onboard 7.1 Audio
Operating System: Vista Ultimate 64-Bit
PSU: 900W EZCool Tornado
Case: Asus TA-210

Thanks

PS. Sorry if this is in the wrong catergory
 

wsupduck

Distinguished
Aug 21, 2009
224
0
18,690
i doubt it but it might be your ram i dont play css but that is my guess. it may be that the server had high ping, have you tried any other servers?
 

HibyPrime

Distinguished
Nov 23, 2006
263
0
18,790
It wont be the ram. I would try reinstalling drivers and if no one else comes up with a better solution, reinstall windows...

There shouldn't be any hardware conflict there, and you should be getting 100+ fps constantly... Whats your monitor resolution?
 

computernewbie

Distinguished
Jan 13, 2009
576
0
18,980
RAM should be fine, thats like....oooh i dident know they made Q8400, i learned something today. Ever consider your PSU might be the one thats bottlenecking your system? Ive never heard of EZCool torando, how do people find these PSU's, seriously. You can also try overclocking your CPU, but i doubt youll get a large performance boost
 

HibyPrime

Distinguished
Nov 23, 2006
263
0
18,790
Even if that PSU is bad enough to only support 50% of its rated load, it's still powerful enough.

This is either a software problem or a hardware defect. There shouldn't be any bottlenecks in that system causing CS:S to run at 40fps