Question System will not post

Dec 2, 2019
1
0
10
0
Hey guys! So I have a Gigabyte GA-H61M-S2H (rev. 1.3) and an i5 2500k. I can't seem to get it to post. It gives me one short beep and turns off within 1 second and reboots with in 2 seconds and loops until I kill the PSU. No video signal. Any suggestions would be greatly appreciated. Steps I've tried myself listed below:

-Swapped PSUs
-Swapped between 2 GPUS: 730gt and 950 GTX
-CMOS reset (like so many times I've lost count, yes this included the battery as well)
-Starting with only GPU and CPU (no heatsink)
-Loosening the heatsink
-Different RAM that I know is working because I stole it from my main PC. Both are clocked below 1600
-Trying one RAM in each dim slot
-Holding the power button
-Holding the reset button and the power button
-Starting with no RAM
-Disconnecting and re-seating the whole thing
-Starting with nothing connected to USB and no HDs
-Any other weird component configuration

All returned the same result as I stated at the beginning of this post. Any help would be greatly appreciated since both ebay sellers have not replied to my messages yet. Worst case scenario I send the items back for a refund. Thanks in advanced!
 

ASK THE COMMUNITY

TRENDING THREADS