Question System wont post with RAM at advertised speed (fixed but not fully)

Jason H.

Honorable
Oct 20, 2013
1,259
61
11,440
51
Okay so my system has worked fine until I updated my bios. Now everytime I either enable XMP or manually set the clock to its advertised speed (3000/2933mhz) the system will not post if I turn the system off then back on.

However when I first set xmp or the manual oc, and save settings in bios and reboot the system will start just fine but when it falls asleep, or I turn it off then back on, it will not post! Also if I just save the bios setring reboot then go into windows, then hit restart from the start button, the system will restart just fine. But when I turn it off or try taking it out of sleep mode, everything turns on but no display.

Ive been running the ram at 3000mhz for months and the only thing that has changed is I updated my bios and I cant go back to the old bios. Evrrytime I try to reinstall the original bios a message pops up in m-flash saying to protect my system and security I cannot go back to an older version.

So I tried using the bios flashback button, and things seem like they are working but the light flashes 3 times then stops without flashing the bios.

Also, when I turn on xmp (2933 15-17-17-36) my bios still says its running at 16-17-17-38 then I go into windows, and in Ryzen master it says cl18! But I even manually set the timings to be cl15 and it still says 16! This HAS to be a bugged bios right?

WHAT TF IS GOING ON?!

EDIT: Issue only happens if the CPU is OCd (even when its ocd from its base clock of 3.4 up to 3.85) and the funny part about that is, 1 its never been an issue til the bios update. And 2 my max boost clock w.o any ocing is 3.9ghz..

EDIT#2 (solution+1 more problem) - i was able to flash the bios back to the bios right before the UI switch. (Not my original bios) the issue with not booting has dissapeared! HOWEVER no matter what I do, even when I manually set the ram timings, it will not go lower than cl 16. I even have it manually set to 15 and it still says 16. (Disabling gear down mode in bios allowed for cl15, issue is I never had to do this for cl15 before)

CPU: R5 2600
MEMORY: HYPERX RGB DDR4 3000MHZ 2X8GB
MOBO: MSI TOMAHAWK B40 (LATEST BIOS VERSION FROM WEBSITE)
GPU: RTX 2060S OC
WINDOWS: WIN 10 PRO
 
Last edited:

Third-Eye

Distinguished
Okay so my system has worked fine until I updated my bios. Now everytime I either enable XMP or manually set the clock to its advertised speed (3000/2933mhz) the system will not post if I turn the system off then back on.

However when I first set xmp or the manual oc, and save settings in bios and reboot the system will start just fine but when it falls asleep, or I turn it off then back on, it will not post! Also if I just save the bios setring reboot then go into windows, then hit restart from the start button, the system will restart just fine. But when I turn it off or try taking it out of sleep mode, everything turns on but no display.

Ive been running the ram at 3000mhz for months and the only thing that has changed is I updated my bios and I cant go back to the old bios. Evrrytime I try to reinstall the original bios a message pops up in m-flash saying to protect my system and security I cannot go back ro an older version.

So I tried using the bios flashback button, and things seem like they are working but the light flashes 3 times then stops without flashing the bios.

WHAT TF IS GOING ON?!

CPU: R5 2600
MEMORY: HYPERX RGB DDR4 3000MHZ 2X8GB
MOBO: MSI TOMAHAWK B40 (LATEST BIOS VERSION FROM WEBSITE)
GPU: RTX 2060S OC
WINDOWS: WIN 10 PRO
Are you making sure to set voltage when manually settings timings? What manual settings are you using and what is the XMP timings? What is the kit model number?
 

Jason H.

Honorable
Oct 20, 2013
1,259
61
11,440
51
Are you making sure to set voltage when manually settings timings? What manual settings are you using and what is the XMP timings? What is the kit model number?
The xmp has always handled it fine by itself. Since Ive had this issue (since I updated the bios) I have tried manually setting the clocks and voltage.

Timings for xmp are 15-17-17-36. And I even set a manual voltage of 1.36 however before updating bios I never had to change that setting. And even at 1.36 it still has the issue.

Also when I manually set itx I set it at exactly what the xmp profile sets it to.

I even had no issues on the old bios at 3200mhz. Im so mad right now.

I even have the option enabled, for 1 try, for if my ram fails, that it reverts it back to its last known working clock and timing, but the bios is not doing that. I have to clear cmos everytime to get back into bios. So Im confident its the bios.

This is the ram. https://www.newegg.com/p/0RN-0003-00177?item=9SIAG7RA855480&source=googleshopping&nm_mc=knc-googlemkp-mobile&cm_mmc=knc-googlemkp-mobile-_-pla-ecmallonline-_-memory+(desktop+memory)-_-9SIAG7RA855480&gclsrc=aw.ds&&gclid=CjwKCAiApOvwBRBUEiwAcZGdGMCvq9eRbCGqMMqlYZX2ZxHdHbUS7T-O0HCo6XpvWd7ZHKyIIwdfaBoCBOYQAvD_BwE

Ive never had an issue with this ram on the old bios. And idk why it wont let me flash back.
 

Third-Eye

Distinguished
Okay so xmp says 15-17-17-36 but the bios has it set to 16, so I changed the 16 to a 15 now it dont start lmao WTF

But with having the "Memory Failure Retry" enabled shouldnt it just revert it back to 16 automatically w.o clearing cmos?!

Also Ive been running on 3.85ghz cpu and cl15 at 3000mhz for months so idk why it would be an issue now with this bios update..

This issue only happens when the cpu is oc'd or I enable game mode. Which its been on game mode since day 1 with no issue for months. Could the bios update have messed it up?

Also even when I set the ram to have 15-17-17-36 manually, when I go into bios it shows I have it set to 15, but it shows that its running at 16.......
You know, if you are running a decent CPU cooler like a Hyper 212 Evo or Deepcool GAMMAXX 400, the CPU will automatically boost itself to 3.7-3.85Ghz on stock settings depending on the game and how much heat is generated. It's why I never bothered to OC my 2600, athlugh I barely saw an fps increase in the games I was playing so i didn't bother to keep my 4.1Ghz OC. Try running on stock and see what you get for speed in the games you play if you are not having issues with your memory without gameboost. Edit - You might even be able to run the CPU's max 3.9Ghz boost if you can dial down the voltage without crashing.
 

Jason H.

Honorable
Oct 20, 2013
1,259
61
11,440
51
You know, if you are running a decent CPU cooler like a Hyper 212 Evo or Deepcool GAMMAXX 400, the CPU will automatically boost itself to 3.7-3.85Ghz on stock settings depending on the game and how much heat is generated. It's why I never bothered to OC my 2600, athlugh I barely saw an fps increase in the games I was playing so i didn't bother to keep my 4.1Ghz OC. Try running on stock and see what you get for speed in the games you play if you are not having issues with your memory without gameboost. Edit - You might even be able to run the CPU's max 3.9Ghz boost if you can dial down the voltage without crashing.
So heres where Im at. I wasnt able to install the original bios but I was able to flash the bios with a version from March 06 2019. Which is about 2 months newer than the original bios. This brought back the old ui. The boot up problem with gamemode and xmp dissapeared. So tjat part has been solved.

NOW Im having this issue where, even though xmp says 15-17-17-36, and even when I manually set the timings to match that, the bios (to the left of the manually entered timing) says 16, not 15. So no matter what, with xmp, or manual settings, my cl is NOT going to 15. And its been at 15 for months.... even when I go into ryzen master, it still says cl16, even though xmp, and my manual settings have it set to cl15.

???

 
Last edited:

Third-Eye

Distinguished
NOW Im having this issue where, even though xmp says 15-17-17-36, and even when I manually set the timings to match that, the bios (to the left of the manually entered timing) says 16, not 15. So no matter what, with xmp, or manual settings, my cl is NOT going to 15. And its been at 15 for months.... even when I go into ryzen master, it still says cl16, even though xmp, and my manual settings have it set to cl15.

???
What do you have for Gear down mode? If it's enabled, it only allows for even cas latency timings. It also helps make your memory over clock more stable. Obviously it has to be turned off when the XMP setting is used
 

Jason H.

Honorable
Oct 20, 2013
1,259
61
11,440
51
What do you have for Gear down mode? If it's enabled, it only allows for even cas latency timings. It also helps make your memory over clock more stable. Obviously it has to be turned off when the XMP setting is used
What is gear down mode? Ive never tuched that setting before and it always ran at cl15 without disabling it.

I found it and it , disabled it, and it allowed cl15 however it changed command rate from 1 to 2....



I manually changed it back to 1. My question thpugh is, why am I having to do all this and I never had to do any of this before?
 

Jason H.

Honorable
Oct 20, 2013
1,259
61
11,440
51
Also, I plan on updgrading my cpu to the 3600 next month so I really hope the same "cant boot" issue doesnt come back when I have to update the bios for the new 3rd gen ryzen... maybe its just an issue with 2nd gen idk, I hope so.
 

Third-Eye

Distinguished
I manually changed it back to 1. My question thpugh is, why am I having to do all this and I never had to do any of this before?
I have no idea why your ram stopped working proper with XMP, but it seems the only way to get it working again is to manually input the timings. You may want to look into using Dram Calculator, because with it, you could likely run tighter timings like 14-14-14-34 1t. You could just try those timings now with sub timings on auto to see if it will even work.
 

Jason H.

Honorable
Oct 20, 2013
1,259
61
11,440
51
I have no idea why your ram stopped working proper with XMP, but it seems the only way to get it working again is to manually input the timings. You may want to look into using Dram Calculator, because with it, you could likely run tighter timings like 14-14-14-34 1t. You could just try those timings now with sub timings on auto to see if it will even work.
I seen online that " fast boot" in bios could possibly be why my pc wont boot into bios or windows with the overclock on the CPU. (on the new bios, works fine on the version I just reverted back too)

When I get my new CPU and go back to that same trash bios, I will try to disable and it see if it works fine. As of right now things are working but everything I had to do was not normal compared to what I had to do before all of this.
 
Last edited:

ASK THE COMMUNITY