System won't post

Apr 13, 2018
1
0
10
0
Yesterday afternoon I just got back to my PC and it was giving me a warning about low storage, I checked and I only had a few hundred mb in my c drive, so I decided to reboot thinking maybe it would reset some things or something, unfortunately windows decided to interject and install an update during the reboot process, a few seconds after the update started it completely froze and when I tried to turn it off even the power button wasn't working, so in order to turn it off I flipped the switch on my power supply, spammed the power button for good measure, then flipped it back and hit the power switch, unfortunately however the system made no indication of booting or even posting, getting no power, so I immediately removed any hardware that could be causing a short somewhere, a wirless card, the hard drives, basically everything but the main components like GPU, RAM, and CPU. Still no luck, there isn't even a light on the Mobo indicating power, I thought maybe my PSU decided to die so I went and got an older one and wired it up, still no luck, I consider myself and avid troubleshooter and enthusiast as I have dealt with many problems similar to this but I just can't seem to solve this one, if my MOBO and PSU are bricked I may just upgrade from my i5-6500 to an i5-7640x with the new Mobo although it would take time for me to get that money. Thanks for any help!



My specs: I5-6500, GTX 980Ti hybrid, 16gb DDR4 2400, MSI gaming m3 Mobo, 1 120gb SSD boot drive and 2 1TB hard drives, a 850watt thermaltake "wicked power" PSU.
 

Turb0Yoda

Dignified
Herald
I would start by unplugging everything except for:

-PSU
-CPU
-CPU Cooler
-One stick of RAM

wire it all up, connect to a monitor, see what happens.


also, I just saw the PSU... that's a piece of crap... might be the issue, not sure what your older one is.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS