• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question System wont start black screen

Jul 16, 2021
2
0
10
0
I have been having serious issues with my pc. I was playing a game and the system switched off with just the fans spinning. After switching off the power I was unable to get post. I made sure all connections where fine, monitor is fine and hdmi cable. Removed memory and used one stick. Had it set so only cpu motherboard and gfx card connected and still could not get post. Also no beeper error codes from board. I thought maybe the psu. I tried psu in my friends pc and got post. I tried my graphics card but got nothing so thought maybe it was that. So I tried my friends gfx card in my pc and nothing. My set up is a ryzen 7 1700, Asus b350 prime, corsair vengeance rgb 32gb.
I thought maybe I have fried my whole system. So I have just bought a Gigabyte 550 Pro a Ryzen 7 3700x and reconnected, with old psu, nothing. No post. I have just got a new Corsair 750w RGB psu, and guess what nothing. This is driving me crazy. Either the PSU has also fried the new motherboard, as when you switch the psu on the leds on the board flash and go off. I just can't understand it. I set up the most basic configuration for the new motherboard, also with my friends gfx card which I know is working. I have also tried different powerpoints in my house to eliminate that, also a different power lead. I have sent the motherboard back and they are sending me a new one. I have thrown the old PSU away so it will never be used again. If the laws of averages are weighing to the most unlucky that's me right now. If anyone has any ideas it would be much appreciated.
 

ASK THE COMMUNITY

TRENDING THREADS