[SOLVED] Task manager says only 7.95 gigs of ram can be used but I have 16gb?

8hy

Nov 4, 2020
9
1
15
0
As the title says, task manager only uses 7.9 gigs of ram when I have 16gb, yet even though both my task manager and if I go to this pc it will show and recognize that I have 16gb ram in. If I go to my bios its main screen says I have 8 gigs of ram, but if I go to a page that tells me the DIMM slots it will say I have 2 sticks of 8 gig ram, I have no idea why this is happening.

990fx Sabertooth r2.0 motherboard
amd 8350 cpu
2x8 gig 1600 mhz ram

Yes, I have changed the ram slots of my ram, still doesn't fix it.
 

Colif

Win 10 Master
Moderator
Switch off PC, remove power socket from mains, press and hold the power button in, release, take side off case, remove CMOS battery for a good few minutes. Replace CMOS battery, put PC back together, making sure the RAM is identical and power the machine back up. A good BIOS reset may resolve. Another thing to try is to knock the RAM timings back manually to a slower speed, that works sometimes as well..
link to similar problem with same board

replacing cmos battery might help since i assume board is old.
 
Jan 9, 2021
47
10
45
2
As the title says, task manager only uses 7.9 gigs of ram when I have 16gb, yet even though both my task manager and if I go to this pc it will show and recognize that I have 16gb ram in. If I go to my bios its main screen says I have 8 gigs of ram, but if I go to a page that tells me the DIMM slots it will say I have 2 sticks of 8 gig ram, I have no idea why this is happening.

990fx Sabertooth r2.0 motherboard
amd 8350 cpu
2x8 gig 1600 mhz ram

Yes, I have changed the ram slots of my ram, still doesn't fix it.
Perhaps one of the sticks are defective? Not sure how well Memtest86 would do in troubleshooting this, but you could give that a try.
 

8hy

Nov 4, 2020
9
1
15
0
Perhaps one of the sticks are defective? Not sure how well Memtest86 would do in troubleshooting this, but you could give that a try.
Memtest didn't detect anything wrong with it, if it were to be defective would my computer still detect both of the sticks like it does?
 

Colif

Win 10 Master
Moderator
As the title says, task manager only uses 7.9 gigs of ram when I have 16gb, yet even though both my task manager and if I go to this pc it will show and recognize that I have 16gb ram in. If I go to my bios its main screen says I have 8 gigs of ram, but if I go to a page that tells me the DIMM slots it will say I have 2 sticks of 8 gig ram, I have no idea why this is happening.
Can you take a photo of the bios screen? and the screens in windows? upload to an image sharing website and show link here.

Windows cannot show you 16gb of ram if your bios is only seeing 8gb. Windows only sees what bios shows it.

Sticks might be fine, its the bios screens that sound odd.
 

8hy

Nov 4, 2020
9
1
15
0
Can you take a photo of the bios screen? and the screens in windows? upload to an image sharing website and show link here.

Windows cannot show you 16gb of ram if your bios is only seeing 8gb. Windows only sees what bios shows it.

Sticks might be fine, its the bios screens that sound odd.
alright give me a quick second
 

8hy

Nov 4, 2020
9
1
15
0
Can you take a photo of the bios screen? and the screens in windows? upload to an image sharing website and show link here.

Windows cannot show you 16gb of ram if your bios is only seeing 8gb. Windows only sees what bios shows it.

Sticks might be fine, its the bios screens that sound odd.
Here you are

Main Screen of bios: https://prnt.sc/wma05b

Showing the DIMM slots on bios: https://prnt.sc/wm9zx3

Task Manager: https://prnt.sc/wm9tau

This pc: https://prnt.sc/wm9tml
 

Colif

Win 10 Master
Moderator
Switch off PC, remove power socket from mains, press and hold the power button in, release, take side off case, remove CMOS battery for a good few minutes. Replace CMOS battery, put PC back together, making sure the RAM is identical and power the machine back up. A good BIOS reset may resolve. Another thing to try is to knock the RAM timings back manually to a slower speed, that works sometimes as well..
link to similar problem with same board

replacing cmos battery might help since i assume board is old.
 

8hy

Nov 4, 2020
9
1
15
0
link to similar problem with same board

replacing cmos battery might help since i assume board is old.
Hey boss, no idea if you'll see this but, I just now bought and replaced my cmos battery, when it booted up the American megatrends screen came up telling me to press f1 to recover bios settings, I have no idea if that would have an effect on things but when I booted to bios it still told me I had 8 gb of ram total, and it also told me the same thing that both dimms were taken up by 2 8gb ram slots. I have no idea why this would happen.
 

Colif

Win 10 Master
Moderator
one suggestion was run with 1 stick at a time and make sure they both work by themselves, as its possibly the slots in motherboard that are at fault.

there are some other ideas here - link

do you have the newest bios for board?
how long has this been going on? Did you replace any of the sticks?
 

ASK THE COMMUNITY

TRENDING THREADS