Taskmgr.exe High CPU Usage.

grah

Distinguished
Jun 17, 2011
25
0
18,530
0
Windows XP SP3
AMD Athlon X2 64 4200+
2GB Ram

Hi all,

After starting up my PC as normal this morning I noticed it was a little slow so I immediately brought up the Task Manager and noticed that taskmgr.exe was using around 12% CPU thus slowing my PC down.

I then opened up the program Process Explorer to see if I could find out a little more information on this.

At first taskmgr.exe was not to be found in Process Explorer so I opened up the Task Manager itself an then it appeared in Process Explorer. I then looked under threads (I have no idea what this is but seemed to remember a while back to look here for more info) and saw 3 processes for taskmgr.exe, 2 of which were using hardly any cpu and then the one below.

taskmgr.exe+0x5944 which is now using around 30% CPU.

I thought at first it could be Avira AV which I uninstalled but the problem still persisted, I have since reinstalled a new version of Avira. It doesn't seem to be link to Comodo Firewall either. The only new programs which I installed since this probelm occured was Wise Registry Cleaner and Sim City 4.

I am very careful with my security setup and would be surprised if this was due to some kind of virus/malware, but this probelm is very annoying. I have not as of yet done a scan with Malware Bytes or Avira as I am wondering if someone has any experience of this before I perform any scans.

I have tried to solve the problem myself and even checking out for solutions on this site but now I am at a loss, plus I am not the most computer savvy either.

Any help is greatly appreciated, thanks for reading.

Grah.

EDIT:

Also in Safe Mode the problem goes away which leads me to believe it's maybe a startup program. Not really sure though, for only a 15% CPU usage it's really slowing down my PC.
 

Dragoic

Honorable
May 5, 2013
164
0
10,710
21
Could you take a screenshots of the task manager while it is having this issue. Also could you take a screenshot where you have sort CPU usage from high to low and one for memory usage too.
 

grah

Distinguished
Jun 17, 2011
25
0
18,530
0


Hi Dragoic, sorry for the wait.







Hope these are as requested.

Also, taskmgr.exe is now around the 15% mark.
 

grah

Distinguished
Jun 17, 2011
25
0
18,530
0


Hi ahnilated,

I'll run a MB soon and see what it finds.

 

grah

Distinguished
Jun 17, 2011
25
0
18,530
0
OK I don't even think this problem is caused by the task manager. My computer feels very sluggish even when task manager isn't running, Process Explorer shows the PC at around 97% idle, so I am not not sure what is causing this sluggishness. RAM usage is very low on idle and the only other thing I can think of is indeed malware/virus maybe. Anyways apologies for the misdirection with regards to the thread title.

Grah.
 

grah

Distinguished
Jun 17, 2011
25
0
18,530
0


Thanks ahnilated I'll try another scan tonight.

Anyways, I think this may be an issue with DirectX, none of my DirectX Features are available for some reason.

Can an Mod close this thread please so I can create a new post in the relevant forum?

Thanks.
 

TRENDING THREADS