TECH: Major Havoc glitches

G

Guest

Guest
Archived from groups: rec.games.video.arcade.collecting (More info?)

Ok, I am having a problem with some graphic glitches on a major havoc board,
on the heads up display screen ( i think that is what it is called )
sometimes there are random giltches/vectors drawn on the screen. but only
on that screen. Thinking a corrupt rom but I dont know, I am thinking of
reading the roms and running them in mame to see if the problem exists in
mame, before I burn some new ones to try. To get it running in the 1st
place, I have replaced the avg chip socket and chip. Chip was dead, and new
one wasnt working good until i replaced the socket. Replaced the socket on
the pokeys and all works pretty well. with the exception of that one screen.
It is all there but there are random flashes of misc vectors on that screen.

Any ideas would be appreciated.

Thanks

John
 
G

Guest

Guest
Archived from groups: rec.games.video.arcade.collecting (More info?)

Is the AVG you put in there used, NOS, or a replacement board?

Actually, though, my MH also throws the random vector about when it's
cycling through the different enemy motherships (determining which one
you're about to face). I think that's by design... the title screen does it
too. What I'm talking about is, when it's drawing the ship, or the title,
when it reaches the end of an object, a line slashes across the screen.

Is that what you mean, or is it actually drawing objects in the wrong place,
etc.?

Rob




"jnhutch" <jnhutch@ev1.net> wrote in message
news:116la759njfjm95@corp.supernews.com...
> Ok, I am having a problem with some graphic glitches on a major havoc
> board, on the heads up display screen ( i think that is what it is
> called ) sometimes there are random giltches/vectors drawn on the screen.
> but only on that screen. Thinking a corrupt rom but I dont know, I am
> thinking of reading the roms and running them in mame to see if the
> problem exists in mame, before I burn some new ones to try. To get it
> running in the 1st place, I have replaced the avg chip socket and chip.
> Chip was dead, and new one wasnt working good until i replaced the socket.
> Replaced the socket on the pokeys and all works pretty well. with the
> exception of that one screen. It is all there but there are random flashes
> of misc vectors on that screen.
>
> Any ideas would be appreciated.
>
> Thanks
>
> John
>
>
 
G

Guest

Guest
Archived from groups: rec.games.video.arcade.collecting (More info?)

While we are on the subject of MH.
My Major Havoc does a wierd thing too.
On the title screen when it draws out "Major Havoc" and then moves it
up and starts running the story line. The top half of "Major Havoc" is
cut off. Would mine be a rom issue? Everything else functions perfect.
 

Mike

Splendid
Apr 1, 2004
3,865
0
22,780
Archived from groups: rec.games.video.arcade.collecting (More info?)

Got is running smooth, replaced the electrolytic caps on the pcb, 3 1uf, and
3 100uf, and replaced the 10mhz crystal.. Runs perfect now. I cant say
which one fixed it, I guess I can go back and put the crystal back in, but I
really think it was the caps. The screen in question has alot going on it,
so I figured there might be a power problem while drawing alot of vectors at
once.

John


"jnhutch" <jnhutch@ev1.net> wrote in message
news:116la759njfjm95@corp.supernews.com...
> Ok, I am having a problem with some graphic glitches on a major havoc
> board, on the heads up display screen ( i think that is what it is
> called ) sometimes there are random giltches/vectors drawn on the screen.
> but only on that screen. Thinking a corrupt rom but I dont know, I am
> thinking of reading the roms and running them in mame to see if the
> problem exists in mame, before I burn some new ones to try. To get it
> running in the 1st place, I have replaced the avg chip socket and chip.
> Chip was dead, and new one wasnt working good until i replaced the socket.
> Replaced the socket on the pokeys and all works pretty well. with the
> exception of that one screen. It is all there but there are random flashes
> of misc vectors on that screen.
>
> Any ideas would be appreciated.
>
> Thanks
>
> John
>
>