Question Technical Issue: Microhpone Causing MME Device Internal Error

Kescarte_DeJudica

Prominent
Jul 18, 2017
3
0
510
Best answers
0
Hello everybody!

So, when attempting to start my livestream today, I was met with a curious error. I opened Adobe Audition, and it told me that it couldn't load my default input and output devices because of an "MME device internal error." So, I opened Windows Sound in Control Panel to check the recording tab and see if there was an issue there. Whenever I went to the recording tab, Sound froze up. The only way to close it was to force it closed with Task Manager.

(For context, I am using a Blue Yeti Micrphone, and running Windows 10.)

The same thing happened when opening it again. Sound froze when going to the recording tab. I could use any other tab, except recording, and it worked fine.

This baffles me completely. I unplugged my Blue Yeti Microphone from the USB port on the back of my computer, and it fixed the issue with Sound. Now, opening up and going to the recording tab worked like normal. But as soon as I plugged it back in, it froze up again.

Now, when I use ASIO instead of MME, the microphone works perfectly fine with my software without error (which is what I ended up having to do, since it was time to stream). The problem is, I don't want to use ASIO since it doesn't work with in-game voice chat, Discord, or most applications since ASIO isn't widely supported like MME is.

What is odd about this is that nothing at all in my setup has changed since I last used the microphone, which was last night. No large Windows updates, no driver updates, no nothing that I can remember. No hardware changes, same microphone, same software, everything!

Now, for what I already tried. I tried restarting the computer, plugging the mic into a different USB port, uninstalling the device from device manager and then reinstalling it. Nothing fixed it.

A quick Google search of this issue returned some results, but for everyone else who experienced the same thing, the solution was to change the Privacy Settings in Windows to allow apps to use your microphone. However, that's not the case for me, because I already had that enabled to begin with.

Again, this came out of nowhere, which makes it very difficult for me to trace the problem back to it's roots. It only started today. I also tested the mic on my mother's laptop, and there was no problem there.

I suspect it is some issue with the driver, but I don't know for sure of course. Any suggestions? Thanks for all your help!
 

ASK THE COMMUNITY

TRENDING THREADS