[SOLVED] Terrible GPU performance

Aug 26, 2021
5
0
10
0
Can someone help me figuring out whats wrong with my GPU?
I was cleaning my PC today and my GPU looked brand new even though I didnt clean my PC for at least 1 year, ive decided to check out my GPU performance if it changed any way and it turned out it indeed did... according to UserBenchmark and my Far Cry 5 benchmark it seems like GPU performance significantly degraded.
UserBenchmark comparison 1 year before and today
Far Cry 5 benchmark 1 year ago
Far Cry 5 benchmark today
Could someone help me finding fix for it? I dont believe my GPU could really lose so much performance especially considering I am not mining or playing heavy GPU consuming games... maybe some settings was changed? there was ton of weird windows updated etc so maybe it changed something? like GPU power limiter or whatever?
tried newest drivers but same results...
before someone asks I didnt change any components of my PC everything is the same including monitor.
Also no artifcats, no other issues I could've noticed on my daily computer usage.
 

Phaaze88

Titan
Ambassador
Your UBM links are broken, but I was still able to look them up manually.

1)Obviously, the gpu stands out, but I'm unsure what the cause is. You did say you cleaned it, so maybe we need to backtrack to the 'how'.
2)BX300: Depending on how one spins it - too full, or capacity too low.
3)Toshiba P300: Might be a good idea to check the health of this drive. If there's a large number of bad sectors, they're going to delay access times.
 

keith12

Illustrious
Hey there,

To start with, I'd ditch using userbench as any way of actually measuring performance. It's not that kinda bench. And there are so many things that could alter the results from one test to another.

For the FC 5 Bench, you have one running at 60hz and the other at 75hz. Why is that? Agree with above ^. Do a clean install of GPU drivers, make sure all system drivers are up to date, and run FC 5 bench again.

Your max FPS in both FC benches are roughly the same, but your min and avg are not. Have you got lots of tasks running in the background? Any overlays? Afterburner OSD or anything? These can all impact FPS during gaming sessions.
 
Aug 26, 2021
5
0
10
0
Thanks for replies.
First of all I thought it shouldnt be necessary to post specs here because as I mentioned in OP specs are exactly the same as year ago but sure...
Windows 10
RTX 2060 MSI Gaming Z
I5-8400
32 GB Ram HyperX 2666mhz
Toshiba P300 3Tb
Crucial BX300 120GB (system drive)
Corsair CX550
@keith12 60hz possibly because i didnt change refresh rate but it doesnt matter since FPS was unlocked and gsync was off in both cases. Monitor is exactly the same AOC g2460vq6 and also I am turning off everything while benchmarking.
 
Last edited:
If you wana compare performance in FC 5, between 1 year ago and today, you must keep all the settings the same. You have 60Hz one year ago and 75 Hz today. Besides that Do you know if there were updates to the game? Cause that also can affect performance of the GPU.

Finally, if you are going to post userbenchmark results, please post the system link results.
 
Can someone help me figuring out whats wrong with my GPU?
I was cleaning my PC today and my GPU looked brand new even though I didnt clean my PC for at least 1 year, ive decided to check out my GPU performance if it changed any way and it turned out it indeed did... according to UserBenchmark and my Far Cry 5 benchmark it seems like GPU performance significantly degraded.
UserBenchmark comparison 1 year before and today
Far Cry 5 benchmark 1 year ago
Far Cry 5 benchmark today
Could someone help me finding fix for it? I dont believe my GPU could really lose so much performance especially considering I am not mining or playing heavy GPU consuming games... maybe some settings was changed? there was ton of weird windows updated etc so maybe it changed something? like GPU power limiter or whatever?
tried newest drivers but same results...
before someone asks I didnt change any components of my PC everything is the same including monitor.
Also no artifcats, no other issues I could've noticed on my daily computer usage.
Post a link to today's UBM run.
 
Aug 26, 2021
5
0
10
0
RodroX Just for you, so people will stop talking about meaningless refresh rate I did another FC5 benchmark with changed refreshrate to 60Hz.
Ta da even worse results, like I said refresh rate doesnt matter because something is clearly wrong somewhere else, UBM benchmarks go crazy too.

and yes its exactly same version of Far Cry 5...
Bob.B here are UBM results from today and I did benchmark few times with same terrible results but it got even worse:
UBM 26.08 result 1
UBM 26.08 result 2
keith12 I am not using geforce experience.
 
Last edited:

Phaaze88

Titan
Ambassador
Your UBM links are broken, but I was still able to look them up manually.

1)Obviously, the gpu stands out, but I'm unsure what the cause is. You did say you cleaned it, so maybe we need to backtrack to the 'how'.
2)BX300: Depending on how one spins it - too full, or capacity too low.
3)Toshiba P300: Might be a good idea to check the health of this drive. If there's a large number of bad sectors, they're going to delay access times.
 
RodroX Just for you, so people will stop talking about meaningless refresh rate I did another FC5 benchmark with changed refreshrate to 60Hz.
Ta da even worse results, like I said refresh rate doesnt matter because something is clearly wrong somewhere else, UBM benchmarks go crazy too.

and yes its exactly same version of Far Cry 5...
Bob.B here are UBM results from today and I did benchmark few times with same <Mod Edit> results but it got even worse:
UBM 26.08 result 1
UBM 26.08 result 2
keith12 I am not using geforce experience.
Just to get it out of the mix your way behind on the bios and you also might need the chipset and management engine driver.
 
Last edited by a moderator:
Reactions: keith12
Aug 26, 2021
5
0
10
0
Your UBM links are broken, but I was still able to look them up manually.

1)Obviously, the gpu stands out, but I'm unsure what the cause is. You did say you cleaned it, so maybe we need to backtrack to the 'how'.
2)BX300: Depending on how one spins it - too full, or capacity too low.
3)Toshiba P300: Might be a good idea to check the health of this drive. If there's a large number of bad sectors, they're going to delay access times.
Thanks for reply,
As of GPU like I said it wasnt even dirty at all so I didnt have to clean it too much just some dust to get rid of on backplate, it looks pretty much brand new.
Both drives have some free space to "breath" BX300 30GB free/120GB and Toshiba 500GB free/3Tb I dont really care about them too much as PC works fine I dont have any issues with that.
Here I care only about this drastic GPU performance degradation as I never noticed any issues with it, I did UBM a lot of times in the past and results were always satisfying pretty much the same as you can see here (full results from year ago):
 

ASK THE COMMUNITY