Question Terrible internet speeds on my OMEN HP Desktop - 870-244

Oct 27, 2021
6
0
10
0
Hi everyone,

I was gifted an older HP Omen computer recently. After setting it up in my room; I've noticed that my network speeds were a lot slower than my other devices in the house despite having a full set of networking bars. To double check, I moved my laptop (its an ASUS Zenbook) next to desktop and ran a speedtest from both computers at once and got a massive difference in the result (ASUS 40-50 mbps) (Omen around 5mbps).
Here is a list of troubleshooting so far:
Updated WLAN drivers
Ran 2 different antivirus software and got 0 results
Cleared out temp files
Checked the task manager and it's currently sitting at around 0% in the network column.
Read somewhere that it might be the Omen command center program is too blame but it is not installed on this computer. I don't know if was uninstalled or it just never had it (this is an older omen model)
Disabled the Microsoft firewall
Move the desktop next to cable modem and plug a ethernet cable to it. Speeds were a little better this isn't an option long term.

I'm running out of ideas. Most of the stuff I've tried above was though google seaches and going though these fourms. Looking for some fresh ideas to try out.

Is there anything else that might be causing the poor internet connection that I can do?
 

kanewolf

Titan
Moderator
Hi everyone,

I was gifted an older HP Omen computer recently. After setting it up in my room; I've noticed that my network speeds were a lot slower than my other devices in the house despite having a full set of networking bars. To double check, I moved my laptop (its an ASUS Zenbook) next to desktop and ran a speedtest from both computers at once and got a massive difference in the result (ASUS 40-50 mbps) (Omen around 5mbps).
Here is a list of troubleshooting so far:
Updated WLAN drivers
Ran 2 different antivirus software and got 0 results
Cleared out temp files
Checked the task manager and it's currently sitting at around 0% in the network column.
Read somewhere that it might be the Omen command center program is too blame but it is not installed on this computer. I don't know if was uninstalled or it just never had it (this is an older omen model)
Disabled the Microsoft firewall
Move the desktop next to cable modem and plug a ethernet cable to it. Speeds were a little better this isn't an option long term.

I'm running out of ideas. Most of the stuff I've tried above was though google seaches and going though these fourms. Looking for some fresh ideas to try out.

Is there anything else that might be causing the poor internet connection that I can do?
What OS? Windows 10? Have you checked the Windows Tuning -- https://www.ghacks.net/2016/08/05/windows-10-limiting-internet-speed/
You want it set to NORMAL
What WIFI device are you using ?
 
Oct 27, 2021
6
0
10
0
It's Win10. Checked the Tuning and the setting was at normal.

Wifi device is coming from Arris DG860P2 cable modem (issued by my ISP). Speaking of which I've power cycled the router late Wednesday night and it seemed to fix the issue up until this morning. For this morning I'm getting an average of 50mbps, but there is a lot of latency or the internet goes out for about 30 seconds - 1 mintue. Still have solid 4-5 bars. I've just power cycle the router again before typing this out. Looking like it's an issue with the modem and not my computer.
 
Oct 27, 2021
6
0
10
0
Yea I have to as my cable modem is in the living room and my computer is currently upstairs. When plugging in the modem itself i get decent speeds (50-60mbps).

Currently I have a repeater plugged in upstairs yesterday and was working well. Right now my speeds have good but now have a lot of drops while playing games on the computer while my laptop next to me is stream twitch videos just fine with no drops what so ever.

Edit: My speeds on my Omen computer has tank to sub 1mbps now. It's increasingly inconstant sense moving it up here.
 
Last edited:

ASK THE COMMUNITY