Question Terrible results on RTX 2080(mobile non max-q) (performance and visual)

Sep 24, 2020
1
0
10
0
Hi all,

Since a few days im having a lot of trouble with my gpu performance wise and visual.
I am using a MSI laptop GE63 Raider RGB 8SG With I7 8750h 16gigs and 2x 500gb SSD.
I used to do undervolting for cpu but for the last few months i changed it back to standard values and applied new paste on CPU/GPU. Performance was very wel

So i did not know how it started but it just came in one day i guess. Performance wise my average FPS got about 35 to 40 percent lower and drops when you don't expect it.
On visual it realy bothers me with very late object loading like geomotry, or like rocks or small trees and bushes etc.. Also the texture filtering doesnt feel like how it is supposed to be. (Tried multiple games)

I have done factory resset a couple of times as wel as switching back to older version of driver and optimizing in control panel. But im not going anywhere im just making it worse.

Im lost, and it is quite fustrating.
If anyone got ideas or a explanation or similar experiences i would appreciate it allot.
 

gabi014

Distinguished
Jul 10, 2012
123
1
18,715
8
1. Have you checked that your GPU or CPU are not overheating and thermal throttling?

2. Do you use your AC adapter plugged in for full performance during gaming? does the AC adapter seems to function normally?

3. Run Furmark test with AC adapter plugged and check if it runs smoothly.
 

ASK THE COMMUNITY

TRENDING THREADS