• Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Question Testing for dead motherboard advice required

Jun 26, 2019
1
0
10
0
I have a build that is 6 months old. The motherboard is an asrock z370 Taichi with an intel 8700K and Seasonic FOCUS 850W Platinum PS. Never been overclocked and I live in a cool climate where temperatures averaged about 70F or 21C so I don't think overheating would be root cause. Normal is 33C-35C for the CPU when I measured it during burn-in.. It has worked flawlessly until Monday when it appeared powered down mid-morning but was functioning monday morning with a screen saver. No lights at all or any signs from the dr.debug led... no fans, nothing just like a dead PS when I attempted to start it. I pulled the 24 pin connector and shorted pins 15/16 and the power supply started up and a chassis fan on the case started. I took my multimeter and took voltages for every pin in the 24 pin connector and I pulled the CPU 12V 8 pin cable for the CPU and tested that. Everything seemed in order and voltages matched what I was expecting at each pin location. I put everything back and shorted the power button pin with ground to attempt and start it and remove the case on/off switch from the equation. No difference. The computer was attached to a trip-lite 1500 UPS.

I have warranty but want to isolate this further given the delays required for swapping out... asrock apparently wants me to ship MB and only then will they ship a replacement up to 5 days after receiving it... so I want to make sure given it could be weeks before I see that replacement MB. This is a box used for programming. I was expecting to hear a beep or see some LED on that motherboard on power on.

Can anyone think of some other tests I could do to pin point this further. At this point, I don't have additional parts to swap or try as my other computer is 14 years old and those parts would not work. :) I was wondering what others would do to isolate root cause before pulling the MB.

Note: There is a brief flash 0.25 seconds which appears to be a blue LED under the ASROCK sign on the MB when you hit the rocker on the PS to on. That ASROCK sign appears to be over the z370 chipset. Pushing start however does nothing nor does attempting to start it from the MB.

This is my first build so I don't have a lot of experience at this point with modern HW. Given it had worked flawlessly and the build went very smoothly, I am at a loss went wrong or what to do do next short of swapping out MB then CPU then PS in that order.

Thank you for reading this and any ideas are much appreciated.
 

Lutfij

Titan
Moderator
I wouldn't bother with the board as ASRock have already stated that they will send you out a replacement for the board. If you were meant to prove that the board truly is dead after normal use(and to prove that it's manufacturer defect) you can make a video of the build and the setup, while breadboarded as documentation.
 

ASK THE COMMUNITY

TRENDING THREADS